Promote Listings Doesn't Work

by Rhadoo7 0 replies
I added my website for sale on the freemarket and I want to Highlight the listing, but it doesn't work.

After I click on "Confirm Payment" I'm taken to a blank page and nothing happens. I tried on 2 different computers and get the same result.

1. Does anyone else have the same issue? Can you promote your listing?

2. Also...does anyone had success in selling a website on the freemarket? If you look in the marketplace and at the most active listings, there are only 11 listings with at least 1 bid...out of 40,000 listed items!!
#freemarket.com discussion #freemarket #listings #promote #promote listings #sell website #work
Avatar of Unregistered

Trending Topics

  • 37 {{ upvoteCount | shortNum }}

    Tons of Bad Advice In This Thread

    Most people that come to the forum are looking for advice on how to build their business or to otherwise make more money. Thanks to all those willing to help ... [read more]

  • 16 {{ upvoteCount | shortNum }}

    Internet Marketing VS Network Marketing

    noobz in Internet Marketing

    Last night I was invited to a small meeting and this guy who is in this one Network Marketing company happens to be the speaker. He claimed to make 6 ... [read more]

  • 3 {{ upvoteCount | shortNum }}

    PLR (private-label rights) content: is there any site that offers GREAT quality content?

    So I've done some research on this forum and have found people talking about PLR sites like PLRAssassin and IDplr, but I was woefully underwhelmed by the quality of the ... [read more]

  • 6 {{ upvoteCount | shortNum }}

    Pls help with designer's english domain name

    panpiotr in SEO

    Hello, my name is Piotr Sierant, I am a graphic designer from Poland, working as a freelance designer for 10 years now and ready to go international and make new ... [read more]

  • 1 {{ upvoteCount | shortNum }}

    Shortening links not working? (bitly, tinyurl, goog.le)

    Ken ny in Internet Marketing

    So I tried shortening some affiliate links but recently it seems like its blocking me from doing so. Does anyone know why? Thanks