Last resort. Please help! Customers cannot add items to their carts.

by Shakila 1 replies
So I have a site http://mybundlesboujee.com. And have been facing this problem since I launched my site in March. The problem is that some (mainly Iphone users) cannot add items to their cart. So if they select their color, and their length and hit "add to cart" or "checkout now", nothing happens. Now, if I visit that same page, I am able to checkout with no problems. As well as all the customers who have successfully made purchases on my site.

The craziest thing about this is that I have tried to hire multiple web designers, and they cannot help because they say they cannot recreate the error. I even contacted the creator of my theme and he believe it's an error on the customers behalf, but I know that is not true. This is the reason why.

So customers who cannot add items to their carts says that they can indeed add an item to their cart if they select the options in black text (I included images below), but if they select the options in purple text and hit add to cart, that's when nothing happens. BUT no option text should be purple, I don't even know why any text is displaying in purple text on any device! All the options should be in black text! And I believe that's were the problem lays! It's just trying to figure out the exact problem that's the challenge I suppose. I have attached a screenshot below of what customers are seeing when they are on the product page before hitting the add to cart button.

Please view this image
upload images

And here's how it displays on my device.

Please view this image

Please if anyone could help, I would greatly appreciate it!

My site is on Opencart's platform version 2.3
#programming #add #carts #customers #items #resort
Avatar of Unregistered
  • Profile picture of the author David Beroff
    The fact that you are observing the word "with" on your elements, (and the mobile customer does not), is a huge clue. It's possible that your server is sending different HTML to the two browsers, but it's even more likely that the HTML being sent is nonconformant in some fashion, and is getting rendered differently on the mobile browser (purple, without the word "with"). Thus, I recommend that you carefully inspect your HTML output using a validator such as https://validator.w3.org/, then fix any and all errors, (even if you feel they "shouldn't matter"). This should improve the chances that different browsers display the pages uniformly.
    Signature
    Put MY voice on YOUR video: AwesomeAmericanAudio.com
    {{ DiscussionBoard.errors[11096752].message }}

Trending Topics

  • 1 {{ upvoteCount | shortNum }}

    Affiliate Website Promotion

    OliverJo in Ad Networks

    Hello, A Newbie here! I am new to Affiliate Marketing. I would like to promote my affiliate website. Please suggest me some good ideas to do that (may be something ... [read more]

  • 37 {{ upvoteCount | shortNum }}

    John Mueller just called SEMRush a "Blackhat Scraper"

    Marcus W K Wong in SEO

    Article here: https://goo.gl/KTL5sC Provoking the thought here: Considering that most, if not all SEO and Content writers consider SEMRush, Moz, RankRanger and other various scraping and SEO tools to be ... [read more]

  • 18 {{ upvoteCount | shortNum }}

    Cool Pitch I found online and thought I would share here

    I was watching a Youtube Video about Pitch Techniques and in the comments, Marco Zegarra, left this below, and it was good enough I wanted to share it with you. ... [read more]

  • 166 {{ upvoteCount | shortNum }}

    Tons of Bad Advice In This Thread

    Most people that come to the forum are looking for advice on how to build their business or to otherwise make more money. Thanks to all those willing to help ... [read more]

  • 72 {{ upvoteCount | shortNum }}

    Are the WSO programs in the WSO section legit?

    Hello I am new to this forum and IM in general How legit are the programs being advertised and promoted in the WSO section of WF? How can I sift ... [read more]