getting php error

by temo1221 6 replies
I have auction website built on php probid software. sometimes website's getting strange error like this:
Warning: include_once(language//global.lang.php): failed to open stream: No such file or directory in /mounted-storage/home134/sub016/sc83398-DKRV/auc.ge/includes/init.php on line 32
Warning: include_once(): Failed opening 'language//global.lang.php' for inclusion (include_path='.:/usr/share/php5/') in /mounted-storage/home134/sub016/sc83398-DKRV/auc.ge/includes/init.php on line 32
Warning: include_once(language//category.lang.php): failed to open stream: No such file or directory in /mounted-storage/home134/sub016/sc83398-DKRV/auc.ge/includes/init.php on line 33
Warning: include_once(): Failed opening 'language//category.lang.php' for inclusion (include_path='.:/usr/share/php5/') in /mounted-storage/home134/sub016/sc83398-DKRV/auc.ge/includes/init.php on line 33
Warning: include_once(language//site.lang.php): failed to open stream: No such file or directory in /mounted-storage/home134/sub016/sc83398-DKRV/auc.ge/includes/init.php on line 36
Warning: include_once(): Failed opening 'language//site.lang.php' for inclusion (include_path='.:/usr/share/php5/') in /mounted-storage/home134/sub016/sc83398-DKRV/auc.ge/includes/init.php on line 36
Warning: include_once(language//categories_array.php): failed to open stream: No such file or directory in /mounted-storage/home134/sub016/sc83398-DKRV/auc.ge/includes/init.php on line 41
Warning: include_once(): Failed opening 'language//categories_array.php' for inclusion (include_path='.:/usr/share/php5/') in /mounted-storage/home134/sub016/sc83398-DKRV/auc.ge/includes/init.php on line 41
Warning: Cannot modify header information - headers already sent by (output started at /mounted-storage/home134/sub016/sc83398-DKRV/auc.ge/includes/init.php:32) in /mounted-storage/home134/sub016/sc83398-DKRV/auc.ge/includes/global.php on line 65
Warning: reset() expects parameter 1 to be array, null given in /mounted-storage/home134/sub016/sc83398-DKRV/auc.ge/global_header.php on line 61php on line 61

error appears once or twice a week, but crashes whole website. then i've to restore mysql and then everything is ok.
does anyone know the solution for this?

Thank you in advance.
#programming #error #php
Avatar of Unregistered
  • Hi,

    Have you got the solution? If not, please consider the following line (or similar):

    Warning: include_once(language//global.lang.php):

    Change it to:
    include_once(language/global.lang.php)

    Regards,

    Bigbanglistbuilding
    {{ DiscussionBoard.errors[7767257].message }}
    • Profile picture of the author temo1221
      Hi @bigbanglistbuilding ,
      Thank you for your reply. But that's not a solution:
      Now init.php code looks like this:
      include_once($fileExtension . "language/" . $session->value("site_lang") . "/global.lang.php");
      include_once($fileExtension . "language/" . $session->value("site_lang") . "/category.lang.php");
      @include_once($fileExtension . "language/" . @$session->value("site_lang") . "/reverse_category.lang.php");
      if (IN_SITE == 1) {
      include_once($fileExtension . "language/" . $session->value("site_lang") . "/site.lang.php");
      }
      if (IN_ADMIN == 1) {
      include_once($fileExtension . "language/" . $setts['admin_lang'] . "/admin.lang.php");
      Now everything works fine, but the error I mentioned in previous post occurs only sometimes (maybe once a week or twice);
      I tried to remove / after "language", but in this way website does not work at all.
      So still don't not know what to do
      {{ DiscussionBoard.errors[7767987].message }}
  • Profile picture of the author KirkMcD
    If you are getting //, it's because session->value("site_lang") isn't set to anything.
    {{ DiscussionBoard.errors[7768969].message }}
    • Profile picture of the author temo1221
      Thank you for replying!
      So if I understand, I must change, for example:
      $session->value("site_lang") . "/category.lang.php");
      to this
      $session->value("category_lang") . "/category.lang.php");

      will this solve this problem?
      {{ DiscussionBoard.errors[7769010].message }}
  • Profile picture of the author SteveJohnson
    No, it won't solve your problem.

    Those sequences are there to allow your visitors to choose what supported language to view the site in. If you have no need of that feature, you can 'force' a specific language. The 'language' folder on your install will have a number of folders corresponding to available translations. In your code, substitute the desired folder name for the $session-value() string.

    Lets say the folder you want to pull language files from is named 'english'. Change your code to:

    include_once($fileExtension . "language/english/global.lang.php");
    Signature

    The 2nd Amendment, 1789 - The Original Homeland Security.

    Gun control means never having to say, "I missed you."

    {{ DiscussionBoard.errors[7769215].message }}
    • Profile picture of the author temo1221
      Thanks for your reply @SteveJohnson.
      I just did what you advised. Hope will not get this stupid error again.
      Thank you!
      {{ DiscussionBoard.errors[7771655].message }}
Avatar of Unregistered

Trending Topics

  • 8 {{ upvoteCount | shortNum }}

    Cool Pitch I found online and thought I would share here

    I was watching a Youtube Video about Pitch Techniques and in the comments, Marco Zegarra, left this below, and it was good enough I wanted to share it with you. ... [read more]

  • 1 {{ upvoteCount | shortNum }}

    Should I submit my site to google now? Also how do I get more visitors, views, and followers?

    unblockedwriter in SEO

    So I've been working on sprucing up my website a bit now and I don't really have any audience at all. The most amount of views I've gotten since I've ... [read more]

  • 2 {{ upvoteCount | shortNum }}

    My website is stuck on page 2

    parthgalhotra in SEO

    I created a website last month, built perfect silo structure, did blog commenting for the page which I wanted to rank and now its stuck on page 2 for my ... [read more]

  • 6 {{ upvoteCount | shortNum }}

    I want to rank one of my image for a keyword in google image search results

    How can I do so? Should I build backlinks directly to the image address or to the page address where the image is uploaded? I don't want to rank in ... [read more]

  • 1 {{ upvoteCount | shortNum }}

    Would like advise please http://smallbusinesstips.me

    williamcondon in Internet Marketing

    I ask experienced Warriors on what to do to get sales happening on my new small business advise site please. I would like to know if affiliates are interested in ... [read more]