Freelancer.com

Go Back   Warrior Forum - The #1 Internet Marketing Forum & Marketplace > Warrior Support Forums > Programming
Register Blogs Social Groups Advertise with usHelp Desk

Reply
LinkBack Thread Tools
Unread 21st February 2013, 03:31 AM   #1
Warrior Member
 
Join Date: 2012
Posts: 21
Thanks: 13
Thanked 1 Time in 1 Post
Default getting php error

I have auction website built on php probid software. sometimes website's getting strange error like this:
Warning: include_once(language//global.lang.php): failed to open stream: No such file or directory in /mounted-storage/home134/sub016/sc83398-DKRV/auc.ge/includes/init.php on line 32
Warning: include_once(): Failed opening 'language//global.lang.php' for inclusion (include_path='.:/usr/share/php5/') in /mounted-storage/home134/sub016/sc83398-DKRV/auc.ge/includes/init.php on line 32
Warning: include_once(language//category.lang.php): failed to open stream: No such file or directory in /mounted-storage/home134/sub016/sc83398-DKRV/auc.ge/includes/init.php on line 33
Warning: include_once(): Failed opening 'language//category.lang.php' for inclusion (include_path='.:/usr/share/php5/') in /mounted-storage/home134/sub016/sc83398-DKRV/auc.ge/includes/init.php on line 33
Warning: include_once(language//site.lang.php): failed to open stream: No such file or directory in /mounted-storage/home134/sub016/sc83398-DKRV/auc.ge/includes/init.php on line 36
Warning: include_once(): Failed opening 'language//site.lang.php' for inclusion (include_path='.:/usr/share/php5/') in /mounted-storage/home134/sub016/sc83398-DKRV/auc.ge/includes/init.php on line 36
Warning: include_once(language//categories_array.php): failed to open stream: No such file or directory in /mounted-storage/home134/sub016/sc83398-DKRV/auc.ge/includes/init.php on line 41
Warning: include_once(): Failed opening 'language//categories_array.php' for inclusion (include_path='.:/usr/share/php5/') in /mounted-storage/home134/sub016/sc83398-DKRV/auc.ge/includes/init.php on line 41
Warning: Cannot modify header information - headers already sent by (output started at /mounted-storage/home134/sub016/sc83398-DKRV/auc.ge/includes/init.php:32) in /mounted-storage/home134/sub016/sc83398-DKRV/auc.ge/includes/global.php on line 65
Warning: reset() expects parameter 1 to be array, null given in /mounted-storage/home134/sub016/sc83398-DKRV/auc.ge/global_header.php on line 61php on line 61

error appears once or twice a week, but crashes whole website. then i've to restore mysql and then everything is ok.
does anyone know the solution for this?

Thank you in advance.
temo1221 is offline   Reply With Quote
Unread 21st February 2013, 03:50 AM   #2
Warrior Member
War Room Member
 
Join Date: 2013
Location: Kolkata, India
Posts: 2
Blog Entries: 6
Thanks: 0
Thanked 1 Time in 1 Post
Default Re: getting php error

Hi,

Have you got the solution? If not, please consider the following line (or similar):

Warning: include_once(language//global.lang.php):

Change it to:
include_once(language/global.lang.php)

Regards,

Bigbanglistbuilding
bigbanglistbuilding is offline   Reply With Quote
Unread 21st February 2013, 08:05 AM   #3
Warrior Member
 
Join Date: 2012
Posts: 21
Thanks: 13
Thanked 1 Time in 1 Post
Default Re: getting php error

Hi @bigbanglistbuilding ,
Thank you for your reply. But that's not a solution:
Now init.php code looks like this:
include_once($fileExtension . "language/" . $session->value("site_lang") . "/global.lang.php");
include_once($fileExtension . "language/" . $session->value("site_lang") . "/category.lang.php");
@include_once($fileExtension . "language/" . @$session->value("site_lang") . "/reverse_category.lang.php");
if (IN_SITE == 1) {
include_once($fileExtension . "language/" . $session->value("site_lang") . "/site.lang.php");
}
if (IN_ADMIN == 1) {
include_once($fileExtension . "language/" . $setts['admin_lang'] . "/admin.lang.php");
Now everything works fine, but the error I mentioned in previous post occurs only sometimes (maybe once a week or twice);
I tried to remove / after "language", but in this way website does not work at all.
So still don't not know what to do
temo1221 is offline   Reply With Quote
Unread 21st February 2013, 11:28 AM   #4
Senior Warrior Member
War Room Member
 
Join Date: 2006
Location: , , USA.
Posts: 2,953
Thanks: 56
Thanked 244 Times in 226 Posts
Default Re: getting php error

If you are getting //, it's because session->value("site_lang") isn't set to anything.
KirkMcD is offline   Reply With Quote
Unread 21st February 2013, 11:36 AM   #5
Warrior Member
 
Join Date: 2012
Posts: 21
Thanks: 13
Thanked 1 Time in 1 Post
Default Re: getting php error

Thank you for replying!
So if I understand, I must change, for example:
$session->value("site_lang") . "/category.lang.php");
to this
$session->value("category_lang") . "/category.lang.php");

will this solve this problem?
temo1221 is offline   Reply With Quote
Unread 21st February 2013, 12:17 PM   #6
Senior Warrior Member
War Room Member
 
SteveJohnson's Avatar
 
Join Date: 2007
Location: Caldwell, Idaho, USA.
Posts: 2,058
Thanks: 682
Thanked 1,624 Times in 961 Posts
Default Re: getting php error

No, it won't solve your problem.

Those sequences are there to allow your visitors to choose what supported language to view the site in. If you have no need of that feature, you can 'force' a specific language. The 'language' folder on your install will have a number of folders corresponding to available translations. In your code, substitute the desired folder name for the $session-value() string.

Lets say the folder you want to pull language files from is named 'english'. Change your code to:

include_once($fileExtension . "language/english/global.lang.php");
SteveJohnson is offline   Reply With Quote
Unread 22nd February 2013, 12:28 AM   #7
Warrior Member
 
Join Date: 2012
Posts: 21
Thanks: 13
Thanked 1 Time in 1 Post
Default Re: getting php error

Thanks for your reply @SteveJohnson.
I just did what you advised. Hope will not get this stupid error again.
Thank you!
temo1221 is offline   Reply With Quote
Reply

  Warrior Forum - The #1 Internet Marketing Forum & Marketplace > Warrior Support Forums > Programming

Bookmarks

Tags
error, php

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




All times are GMT -6. The time now is 08:22 PM.