[Fixed] Replies to closed threads/forums

by David Beroff 10 replies
I'm assuming that this is a bug, although perhaps it's just a matter of my not knowing the secret handshake.

Take a look at this article from 2013:
http://www.warriorforum.com/articles...-articles.html

Notice that there isn't any reply button, (at least I can't see one). How did someone just reply to the thread, (and others), then? Should this hole get closed, or again, is there some sort of secret override of which I should be aware?

Also, this looks like a second, but related, bug: For purposes of this report, I tried to reply to the same thread using this URL:
http://www.warriorforum.com/newreply...ote=1&p=860261
(i.e., guessing the above secret handshake).

Not only was my reply not rejected, but oddly, it got posted to an entirely unrelated thread from '09:
http://www.warriorforum.com/main-int...c#post11028760
(which I promptly self-reported, so it may no longer be showing).

Something very odd is afoot here.
#suggestion forum #closed #replies #threads or forums
Avatar of Unregistered
  • Profile picture of the author DWolfe
    Might be a bug. Took a look at both threads their were no new replies there in classic view. But I could Thank the OP in either one if I want to. Just to bad you can not remove "Thanks" here now a days.
    {{ DiscussionBoard.errors[11028856].message }}
    • Profile picture of the author David Beroff
      Originally Posted by DWolfe View Post

      Took a look at both threads their were no new replies there in classic view.
      Both replies are now gone. But I'm pretty sure the bug itself is still present.
      {{ DiscussionBoard.errors[11028857].message }}
      Signature
      Put MY voice on YOUR video: AwesomeAmericanAudio.com
  • Profile picture of the author agmccall
    It is in the articles sub forum, I thought all posts in that area are closed. Why, I do not know

    al
    {{ DiscussionBoard.errors[11029197].message }}
    Signature
    If there are no stupid questions, then what kind of questions do stupid people ask? Do they get smart just in time to ask questions?~Scott Adams~
    • Profile picture of the author David Beroff
      Originally Posted by agmccall View Post

      It is in the articles sub forum, I thought all posts in that area are closed.
      Right; so you are agreeing with me that it's a bug, yes?
      {{ DiscussionBoard.errors[11029207].message }}
      Signature
      Put MY voice on YOUR video: AwesomeAmericanAudio.com
      • Profile picture of the author pauloadaoag
        Administrator
        Originally Posted by David Beroff View Post

        Right; so you are agreeing with me that it's a bug, yes?
        yeah its a bug. we will fix this week, thanks for bringing this to our attention
        {{ DiscussionBoard.errors[11030034].message }}
        Signature
  • Profile picture of the author nmcalabroso
    Administrator
    Yes, this is bug. Users were able to reply to the threads in closed forums (e.g. Articles) using the modern view. We're going to roll out a fix for this.
    {{ DiscussionBoard.errors[11031852].message }}
  • Profile picture of the author nmcalabroso
    Administrator
    We've fixed this issue. Users who will try to reply in any closed thread, or thread in closed forum will get a proper error message.

    Let us know if the problem still persists. Thanks.
    {{ DiscussionBoard.errors[11033846].message }}
  • Profile picture of the author David Beroff
    Thanks, but sorry; I was just able to reproduce the second half of my original bug report, following the steps I gave previously.
    {{ DiscussionBoard.errors[11033927].message }}
    Signature
    Put MY voice on YOUR video: AwesomeAmericanAudio.com
    • Profile picture of the author nmcalabroso
      Administrator
      Originally Posted by David Beroff View Post

      Thanks, but sorry; I was just able to reproduce the second half of my original bug report, following the steps I gave previously.
      Ah that one is not a bug.

      What you're trying to do here is to reply to the thread with id: 860261. However, the link you used is /newreply.php?p=860261 which of course, is invalid since that "p" represents post id and not thread id.
      {{ DiscussionBoard.errors[11033966].message }}
      • Profile picture of the author David Beroff
        Originally Posted by nmcalabroso View Post

        Ah that one is not a bug.

        What you're trying to do here is to reply to the thread with id: 860261. However, the link you used is /newreply.php?p=860261 which of course, is invalid since that "p" represents post id and not thread id.
        Interesting! OK; you got me there!
        (Guess I'd better go back to hacker school, then.)
        {{ DiscussionBoard.errors[11033972].message }}
        Signature
        Put MY voice on YOUR video: AwesomeAmericanAudio.com
  • Profile picture of the author Boy Zodiac
    [DELETED]
    {{ DiscussionBoard.errors[11033956].message }}

Trending Topics