What is going on with Google Search?

11 replies
I put a search term in Google and pulled up the list. I wanted to see keywords at end. But as I get down to bottom of page, I see, jump to page... and it just wouldn't stop loading more pages. This is not what I want and I don't want to tie up my browser pulling up all these pages.

Has anyone else experienced this? It wasn't happening a few hours ago to the best of my knowledge. Or maybe I just didn't notice it.
#google #search
  • Profile picture of the author dana67
    Google seems to be working correctly for me. I wasn't able to repeat this issue.
    {{ DiscussionBoard.errors[10386146].message }}
  • Profile picture of the author FromCook2King
    Do you have an extension or something.

    If you have done nothing, G cold be split testing something on users.
    {{ DiscussionBoard.errors[10386183].message }}
  • Profile picture of the author arikakarim1
    Just now I checked in the google, it is working good. If it rally had, there may problem. AS the google is one of the best search engine, it must be solved when the authority will know. You can check it again. Thanks a lot.
    {{ DiscussionBoard.errors[10387293].message }}
  • Profile picture of the author Alex The Lion
    A screenshot would have helped a great deal
    {{ DiscussionBoard.errors[10387324].message }}
  • Profile picture of the author wlasikiewicz
    Just seen your post but the big G is working ok for me on Safari
    {{ DiscussionBoard.errors[10387335].message }}
  • Profile picture of the author salegurus
    Tim, you should know that the Main forum isn't the right place for this specific thread....
    Signature
    Think of how stupid the average person is, and realize half of them are stupider than that.

    ― George Carlin
    {{ DiscussionBoard.errors[10387595].message }}
    • Profile picture of the author timpears
      Originally Posted by salegurus View Post

      Tim, you should know that the Main forum isn't the right place for this specific thread....
      Really, when I didn't know. Sorry I am stupid, but this looked like a good place to put it. But if I am wrong, then I guess it ain't the first time, or the last I am sure.

      Nice of you to tell me WHICH forum it SHOULD have gone in according to your rules.
      Signature

      Tim Pears

      {{ DiscussionBoard.errors[10387871].message }}
      • Profile picture of the author paulnedo
        Originally Posted by timpears View Post

        Really, when I didn't know. Sorry I am stupid, but this looked like a good place to put it. But if I am wrong, then I guess it ain't the first time, or the last I am sure.

        Nice of you to tell me WHICH forum it SHOULD have gone in according to your rules.
        No need to get snippy, we're trying to help you here

        And, yes, my Google is working just fine.
        {{ DiscussionBoard.errors[10388107].message }}
  • Profile picture of the author LogoShield
    Infinite scroll virus
    {{ DiscussionBoard.errors[10387608].message }}
  • Profile picture of the author vishwa
    Not see any similar problem with my side.
    Signature

    Blogging Tips & Tricks @ https://www.blogwithvk.com

    {{ DiscussionBoard.errors[10388206].message }}
  • Profile picture of the author arikakarim1
    I had checked with the many browser, there is no problem. Do you feel this problem still now? If yes, could you please to show us by a screen shot? Thanks a lot.
    {{ DiscussionBoard.errors[10388433].message }}

Trending Topics