Any Wordpress Experts?

14 replies
Hey Warriors,

I am having a bit of trouble with my Wordpress blog.

The problem is is that under some of my posts where the number of comments are supposed to be shown it says "no comments" even though I have comments.

If I click the "no comments" button it takes me to the comments that have been left.

I have changed the php code in the comments.php file from "no comments" to "comments" but this has not made any difference.

I am not by any means a php expert so maybe I am not doing it right or going about it the wrong way.

Any help would be great

Thanks
Adam
#experts #wordpress
  • Profile picture of the author gixxer
    Not sure on that one, man. Have you googled the problem and checked the WP Codex?

    Adam
    {{ DiscussionBoard.errors[2239094].message }}
  • Profile picture of the author Quentin
    If you change the the default theme in wordpress do you get the same problem?

    Quentin
    {{ DiscussionBoard.errors[2239127].message }}
    • Profile picture of the author Adam Sandford
      @ Gixxer, Yeah mate I have searched google and the Worpress codex but I just can't seem to sort it out.

      @ Quentin, That was the first thing I tried and I have also tried 3 other themes and still the same problem.

      I know it is not a huge problem but its just got under my skin and i'm not stopping until I get it sorted.

      Thanks guys

      Adam
      {{ DiscussionBoard.errors[2239137].message }}
  • Profile picture of the author JayXtreme
    Adam..

    Take a look in your index.php file, or home.php (whichever is used for your main page) and look for this bit of code:

    Code:
    <?php comments_popup_link('No Comments »', '1 Comment »', '% Comments »'); ?>
    I'm just heading out right now... but I will check back to this thread later and see what we can do
    Signature

    Bare Murkage.........

    {{ DiscussionBoard.errors[2239167].message }}
  • Profile picture of the author NK
    Did you upgrade to 3.0? I've heard that 3.0 breaks a lot of old codes used in theme.
    Signature

    Affiliate Link Cloaking & Tracking Software - The most powerful tool available for affiliate marketers who are sick and tired of making way too little money!
    {{ DiscussionBoard.errors[2239280].message }}
  • Profile picture of the author kanon78
    Banned
    [DELETED]
    {{ DiscussionBoard.errors[2239316].message }}
  • Profile picture of the author VegasGreg
    Are the comments approved or awaiting moderation? They could be waiting for approval, though since you are logged in as administrator you can still see them.

    Or you have the WP-Super-Cache plugin installed and you may have to refresh the screen 143 times before it actually updates for you. (You can disable the plugin and refresh to try it).

    Those would be my first 2 guesses without further review.
    Signature

    Greg Schueler - Wordpress Fanatic... Living The Offline Marketing Dream...

    {{ DiscussionBoard.errors[2246548].message }}
    • Profile picture of the author Shannon Herod
      I had a similar problem with one of my WordPress sites.

      The problem was inside of a plug-in. I activated a comment plug-in, which I do not learn what it was, but when I deactivated it, it took all of my comments with it.

      Also, if you have used the plug-in discuss, all of your comments are by then, not on your own blog. So, if you deactivate that plug-in, your comments are gone.

      That might be the issue.

      Also, try deactivating all of your plug-ins and see if your comments come back. If the comments come back then reactivate your plug-ins one at a time and keep checking your comments. when you activate the plug-in that deletes the comments you know the culprit.
      {{ DiscussionBoard.errors[2246570].message }}
    • Profile picture of the author Adam Sandford
      Thanks all,

      The comments are all approved and when I click where it says "no comments" I can then see the comments that have been left. This only happens on some of my posts too,mmmm very strange

      Also I have disabled all of the plugins that I have and still the same problem,

      Not really sure what else I can do as I have tried all the ways I know and everything suggested by other Warriors.

      Thanks so much everyone I will contact Sherice to take her up on her offer of help

      Cheers

      Adam
      {{ DiscussionBoard.errors[2246835].message }}
  • Profile picture of the author ecoverartist
    If you've tried all of the suggestions above and still aren't having any luck - shoot me an email -- sherice (at) ielectrify . com and I'd be glad to look into it for you. I eat, live and breathe Wordpress
    {{ DiscussionBoard.errors[2246571].message }}
  • Profile picture of the author mikeevee
    Its odd. Not one I have seen myself.

    Could it be that you are running a cache like Super Cache or Total Cache and it is showing you an older version of the page?
    Signature
    {{ DiscussionBoard.errors[2246847].message }}

Trending Topics