WordPress Slow Page Load Time Problems & Solutions

28 replies
My blog bosmol [dot] com has been receiving significantly more traffic in the past few months, but has a huge bounce rate. I believe it is due to the slow loading pages. The homepage loads quick, but the individual posts take forever to load. If anyone has any advice I would appreciate it.

I have removed many plug-ins and installed WP Total Cache

This has helped but it still runs very slow.

THANKS!!!
#load #page #problems #slow #solutions #time #wordpress
  • Profile picture of the author VegasGreg
    Wow, over 1 minute to load one of the back pages (posts). I didn't see anything on the home page, but when I clicked to view an article it hung up bad while loading:
    Code:
    static.fbshare.me
    Signature

    Greg Schueler - Wordpress Fanatic... Living The Offline Marketing Dream...

    {{ DiscussionBoard.errors[4250622].message }}
  • Profile picture of the author terryd
    Caching plugins and optimize your images a bit more should bring the speed down.....

    WebPagetest Test Result - Dulles : bosmol.com - 07/13/11 06:38:54

    Was going to include test results from one of your posts but it timed out
    Signature

    {{ DiscussionBoard.errors[4251035].message }}
  • Profile picture of the author ZilvinasJuraska
    The posts really take huge time to load..

    My guess is that there are some problems with theme. Try installing another theme.

    Also plugin that may help a bit: wordpress gzip compression.
    {{ DiscussionBoard.errors[4251067].message }}
  • Profile picture of the author HigherPrThanGod
    Originally Posted by bosmolskate View Post

    My blog bosmol [dot] com has been receiving significantly more traffic in the past few months, but has a huge bounce rate. I believe it is due to the slow loading pages. The homepage loads quick, but the individual posts take forever to load. If anyone has any advice I would appreciate it.

    I have removed many plug-ins and installed WP Total Cache

    This has helped but it still runs very slow.

    THANKS!!!
    Who's your host? Tortoise Hosting?
    {{ DiscussionBoard.errors[4251085].message }}
    • Profile picture of the author BubbaJay
      If you're on GoDaddy hosting - get off it.

      Also delete any plugins you're not using, every plugin loads on every page, every time whether or not you're using it.
      {{ DiscussionBoard.errors[4251099].message }}
  • Profile picture of the author Abledragon
    If you have W3-Total-Cache running you may want to check the settings. None of your Thesis stylesheets are cached, and that maybe because you're still on v 1.7, which still used the appended date stamps on each css file. W3TC could'nt cope with that, but version 1.8.1 fixed that problem. It would be well worth updating.

    Nothing much else seems to be cached either.

    The settings for W3TC are affected by the server your site is running on, so you should ask your hosting provider what settings they recommend. As a starter, though, this is how I set up my version of W3TC:

    W3-Total-Cache: How to Set it Up | WealthyDragon

    Apart from that, your social_fixed div with those social media buttons on the left of your content div may well be the culprit - try moving it to the right of your container div so it loads after the rest of the page. (You already have 4 more social media buttons on the right - you surely don't need them twice?).

    For me the pageload hung while trying to load this JS file: http://d.yimg.com/ds/badge2.js. Again, move whatever that script refers to over to the right, or in a sidebar near the bottom.

    This article goes through ways to position stuff on your page so it appears to load faster:

    Make Site Pages Load More Quickly | WealthyDragon

    That may help a bit,

    Cheers,

    Martin.
    Signature
    WealthyDragon - Earning My Living Online
    {{ DiscussionBoard.errors[4251218].message }}
    • Profile picture of the author bosmolskate
      Originally Posted by VegasGreg View Post

      Wow, over 1 minute to load one of the back pages (posts). I didn't see anything on the home page, but when I clicked to view an article it hung up bad while loading:
      Code:
      static.fbshare.me
      I know, that is exactly the problem

      Originally Posted by ZilvinasJuraska View Post

      The posts really take huge time to load..

      My guess is that there are some problems with theme. Try installing another theme.

      Also plugin that may help a bit: wordpress gzip compression.
      I have Theses V 1.7 framework installed

      Originally Posted by HigherPrThanGod View Post

      Who's your host? Tortoise Hosting?
      Im using BlueHost

      Originally Posted by BubbaJay View Post

      If you're on GoDaddy hosting - get off it.

      Also delete any plugins you're not using, every plugin loads on every page, every time whether or not you're using it.
      I have done this. I only use the bare minimum plug-ins. The rest I have custom coded into the page by someone on freelancer. This may be causing the slow load times.

      Originally Posted by Abledragon View Post

      If you have W3-Total-Cache running you may want to check the settings. None of your Thesis stylesheets are cached, and that maybe because you're still on v 1.7, which still used the appended date stamps on each css file. W3TC could'nt cope with that, but version 1.8.1 fixed that problem. It would be well worth updating.

      Nothing much else seems to be cached either.

      The settings for W3TC are affected by the server your site is running on, so you should ask your hosting provider what settings they recommend. As a starter, though, this is how I set up my version of W3TC:

      W3-Total-Cache: How to Set it Up | WealthyDragon

      Apart from that, your social_fixed div with those social media buttons on the left of your content div may well be the culprit - try moving it to the right of your container div so it loads after the rest of the page. (You already have 4 more social media buttons on the right - you surely don't need them twice?).

      For me the pageload hung while trying to load this JS file: http://d.yimg.com/ds/badge2.js. Again, move whatever that script refers to over to the right, or in a sidebar near the bottom.

      This article goes through ways to position stuff on your page so it appears to load faster:

      Make Site Pages Load More Quickly | WealthyDragon

      That may help a bit,

      Cheers,

      Martin.
      Awesome info! I was wondering if there is a way to upgrade my version of thesis for free? Also, how do I find out what http://d.yimg.com/ds/badge2.js refers to? I am not good at coding and outsourced some custom plug ins to my theme to use less room, but it seems that the floating icons on the left may be causing the slow down. I will definitely check out the article

      Originally Posted by terryd View Post

      Caching plugins and optimize your images a bit more should bring the speed down.....

      WebPagetest Test Result - Dulles : bosmol.com - 07/13/11 06:38:54

      Was going to include test results from one of your posts but it timed out
      Haha, thanks for the test and I completely understand why you did not test interior pages.
      Signature
      {{ DiscussionBoard.errors[4264531].message }}
  • Profile picture of the author christopher jon
    static.fbshare.me
    That is your problem. Dump it and you'll see a huge improvement.

    As a matter of fact, your page is social media overkill. You have at least 4 different places on your page with social media buttons plus those badges at the bottom of your side bar. All of that is killing your load time.

    If you're on GoDaddy hosting - get off it.
    Im using BlueHost
    OH Snap!
    Signature
    It buys my product or it gets the hose
    {{ DiscussionBoard.errors[4264557].message }}
    • Profile picture of the author bosmolskate
      Originally Posted by christopher jon View Post

      That is your problem. Dump it and you'll see a huge improvement.

      As a matter of fact, your page is social media overkill. You have at least 4 different places on your page with social media buttons plus those badges at the bottom of your side bar. All of that is killing your load time.



      OH Snap!
      Should I remove the custom coding that the freelancers did and just reinstall the Digg Digg plug-in? I though custom coding would increase load time? Is there a way to fix the fb lag?

      The badges at the bottom right really slow down the load time?

      I will remove the floating icons on the right as they are overkill. They lead to my personal pages, yet people probable have no idea where the icons lead out to.
      Signature
      {{ DiscussionBoard.errors[4264718].message }}
  • Profile picture of the author christopher jon
    I though custom coding would increase load time? Is there a way to fix the fb lag?
    Not much you can do about it since you're waiting on FB. Twitter is also taking forever to load.

    I'd remove everything you can and see how that effects your load time. After that, experiment until you find a combination with an acceptable load time. Maybe test out some similar social plugins and see if they are any faster.
    Signature
    It buys my product or it gets the hose
    {{ DiscussionBoard.errors[4264783].message }}
  • Profile picture of the author Abledragon
    You can update Thesis for free - just log in to your DIYThemes account and download the latest version.

    If you want to do custom coding you should do it in the Thesis custom functions file, because that way your customisations will be preserved through both Thesis and WordPress upgrades.

    Cheers,

    Martin.
    Signature
    WealthyDragon - Earning My Living Online
    {{ DiscussionBoard.errors[4264936].message }}
  • Profile picture of the author Targeted Traffic
    -Deactivate all your plugins

    -Re-activate your plugins a few a time

    -Keep re-activating a few plugins at a time and checking page load speed each time.Delete that slow-working plugin.
    {{ DiscussionBoard.errors[4266329].message }}
  • Profile picture of the author dking1
    The best thing really is to reduce the installed pluggins and other heavy program
    {{ DiscussionBoard.errors[4266342].message }}
  • Profile picture of the author christopher jon
    Something that I didn't think of yesterday,

    When your using a lot of javascript, like your social plugins, it's always best to put that code in your footer, not your header. This way your site loads first and then the javascript loads.
    Signature
    It buys my product or it gets the hose
    {{ DiscussionBoard.errors[4267611].message }}
    • Profile picture of the author bosmolskate
      Originally Posted by christopher jon View Post

      Something that I didn't think of yesterday,

      When your using a lot of javascript, like your social plugins, it's always best to put that code in your footer, not your header. This way your site loads first and then the javascript loads.

      How would I do that? I am a newb when it comes to coding

      THANK YOU!

      My site is sooo much faster, yet it is still slow lol

      I have removed the floating icons, but now when browsing using IE when I go into individual posts the formatting cuts off and looks weird. The pages and homepage look fine, but the individual posts are cut off. Does anyone know why this may occur?

      I also tried using the Digg Digg plug in but it screwed up the formatting on all browsers
      Signature
      {{ DiscussionBoard.errors[4270973].message }}
  • Profile picture of the author bosmolskate
    Does anyone know why my website is not showing up properly when using Internet Explorer.

    My blog is Bosmol – Social Media & Web 2.0 Internet Marketing News

    I appreciate any help!!
    Signature
    {{ DiscussionBoard.errors[4296477].message }}
  • Profile picture of the author bosmolskate
    The blog looks fine on the homepage but when you view example posts it gets cut off.

    Example Post) Pope Benedict XVI First Tweet on Twitter
    Signature
    {{ DiscussionBoard.errors[4296873].message }}
  • Profile picture of the author GoldenGlovez
    Are you using shared hosting? I've always had problems with page load speed no matter what I tried using with shared hosting. It's definitely worth the money and time to upgrade your server to a trusted VPS or Dedicated server(Depending on your budget and site value).
    {{ DiscussionBoard.errors[4296898].message }}
  • Profile picture of the author christopher jon
    How would I do that? I am a newb when it comes to coding
    You're asking me to give away ancient Chinese secrets!

    Your sites load time isn't too bad now.

    I noticed your comments are getting a lot of love from spammers.
    Signature
    It buys my product or it gets the hose
    {{ DiscussionBoard.errors[4296994].message }}
  • Profile picture of the author Mike Adams
    Start using CloudFlare, its great!
    Signature
    P.S. If you found my post useful, please click the "Thanks" button below...
    {{ DiscussionBoard.errors[4297006].message }}
  • Profile picture of the author Lyanna
    Akismet is your friend. Try it and those spam comments will go away forever.
    {{ DiscussionBoard.errors[4297224].message }}
  • Profile picture of the author bosmolskate
    Any idea on how to fix this? I am in desperate need of help so any advice is greatly appreciated. I am even wiling to hire someone to help
    Signature
    {{ DiscussionBoard.errors[4337849].message }}
  • Profile picture of the author n1985
    Ok now I am also experiencing the same thing. At first I thought it was my browser or connection.
    {{ DiscussionBoard.errors[4337888].message }}
  • Profile picture of the author JustFelix
    Use Thesis, I got tired of using all these pro blogs with insane design when it loads slow. I went with the basic Thesis, and I've gotten a lot more traffic with it. Another thing is it loads so fast for me.
    {{ DiscussionBoard.errors[4337905].message }}
    • Profile picture of the author bosmolskate
      Originally Posted by n1985 View Post

      Ok now I am also experiencing the same thing. At first I thought it was my browser or connection.
      Any idea what may cause this? What browsers did you notice the problem?

      Originally Posted by JustFelix View Post

      Use Thesis, I got tired of using all these pro blogs with insane design when it loads slow. I went with the basic Thesis, and I've gotten a lot more traffic with it. Another thing is it loads so fast for me.
      This is Thesis
      Signature
      {{ DiscussionBoard.errors[4342009].message }}

Trending Topics