Your Google +1 plugin is costing you viewers, and you probably don't even realize it.

6 replies
The G+1 addon/plugin/whatever you wanna call it - Yep. Its taking away from your traffic.

EVERY site that has this enabled, takes AT LEAST 2 "refreshes" to load the actual content of the page - Or at least for me it does, but I surely can't be the only one.

The first time you load the page, nothing comes up. It just keeps looping the "wait" - and in the status bar, its ALWAYS the google +1 never finishes loading.

When you stop the page from loading & then click refresh, miraculously, it loads without problems.

However, not many people are aware of this.

When that page doesn't load the FIRST time, they close it and move on - Just like I used to do until I found out that was the problem.

So yea.. something you guys might want to think about before you go adding that +1 plugin/addon/whatever to your site.
#costing #google #plugin #realize #viewers
  • Profile picture of the author rowbot
    I have it on dozens of pages and don't have the problem you described. The pages load fine for me in several different browsers.
    Signature

    Mess with me and you mess with the whole trailer park.

    {{ DiscussionBoard.errors[7330588].message }}
    • Profile picture of the author Fredbou
      I have it too, on hundreds of Web pages on many, many sites and have never seen the problem!

      Can you post the page?
      Signature

      {{ DiscussionBoard.errors[7330636].message }}
      • Profile picture of the author brentb
        Dude, it's not a problem with G+, its something with your browser, browser plugin or javascript. Try re-installing it all fresh. That should help.
        {{ DiscussionBoard.errors[7330661].message }}
  • Profile picture of the author techbul
    I'm also not experiencing this issue, and I have a lot of websites.
    I am pretty sure Google wouldn't make such a mistake.
    {{ DiscussionBoard.errors[7330916].message }}
  • Profile picture of the author SEO Haven
    Originally Posted by Whos That Guru View Post

    EVERY site that has this enabled, takes AT LEAST 2 "refreshes" to load the actual content of the page
    My suggestion is getting a better web hosting provider, I've never had any problems and we have much more than just a G+ button.

    Problem: Either your web host sucks, or you have too much Javascripts running on your site that's eating up your bandwidth.
    Signature
    All-In-One SEO & Marketing Service
    If you want the upper hand over your competitors, here's your chance.
    SEO, SMM, Google Local Optimization & Professional Internet Marketing done-for-you.
    Never worry about Traffic & Lead Generation again! Click Here for more info.
    {{ DiscussionBoard.errors[7330923].message }}
  • Profile picture of the author Robert Michael
    I'm not talking about on MY sites.. This is happening on ANY site I go to that has G+1 enabled.

    As for my browser, its the newest Firefox with no addons/extensions.. can't be causing it.

    I'll take a video of it sometime today & post it so you guys can see what I'm talking about.

    Might be awhile tho cuz I just woke up
    {{ DiscussionBoard.errors[7332360].message }}

Trending Topics