WordPress site running slow... suggestions?

12 replies
**EDIT: Looks like it was a plugin I was running. See post #11 if you care to know which one.**

I have 6 WordPress sites running on a shared hosting plan through Host Gator. With the exception of one, they are all very small sites (only a few pages.) I have Total Cache installed. They all run slow to extremely slow.

Is there anything I can do to speed WordPress up, or do I need to upgrade my hosting plan?

Thanks in advance for any helpful replies!
#running #site #slow #suggestions #wordpress
  • Profile picture of the author Dan Thompson
    Try disabling all plugins and then retrying, if the site speeds improve then it's likely a badly coded plugin causing the issue. To identify it you can re-enable them all 1 by 1 until you find the culprit!

    Failing that, switch back to one of the default Wordpress themes and see if that makes a difference. If it does, then the theme you are using will be the cause.

    If it was an issue with the server your account resides on then you'd expect to see the same slowness across all sites, but as you've said that you have one that is running normally which would seem to rule out a server issue....unless you have the accounts spread across multiple servers?
    Signature

    I'm a director of D9 Hosting
    The only host in the world to offer a 1 Click DLGuard installation feature from within the cPanel.
    Join today, and receive a 10% discount by using the following coupon code: Warriors

    {{ DiscussionBoard.errors[8215414].message }}
    • Profile picture of the author Matt011
      Thanks, I'll give that a try and report back. The theme on the site that needs to be running fast (for business purposes) is OptimizePress.

      In regards to your last paragraph: all my sites ARE running slow. Not just the one.

      EDIT: Just kidding... I checked my other sites and most of them are running fine. Apparently it's only a few of them that are slow. Time to check my plugins...
      {{ DiscussionBoard.errors[8215425].message }}
      • Profile picture of the author Dan Thompson
        Ahh, sorry, I misread!

        If you think it's a server issue then contact HG, their isn't really anything you can use from your end to check the server status. If you have a reseller account you might have active to the "Service Status" page where you can see the server load and RAM usage but these aren't always the best indicators of a servers performance, so contacting your host would be the best bet.

        Edit: Just seen your edit, in that case ignore what I just said :-D
        Signature

        I'm a director of D9 Hosting
        The only host in the world to offer a 1 Click DLGuard installation feature from within the cPanel.
        Join today, and receive a 10% discount by using the following coupon code: Warriors

        {{ DiscussionBoard.errors[8215449].message }}
  • Profile picture of the author jaimegm
    Something that has worked fine for me is to make the wordpress page and then save it only as html, (that is if you are not using dynamically something from a database) and this helps the reason is because sometimes the php sever is very busy
    Signature

    Free course about free from Youtube Twitter or Email at www.realistic100aday.com

    {{ DiscussionBoard.errors[8215461].message }}
  • Profile picture of the author Matt011
    This is so weird... the site has been slow for at least a week or more, and now it seems to be working fine...

    Anyone mind visiting these links and letting me know if they load any slower than other sites?

    http://www.reimadesimple.com/25-to-1
    http://www.reimadesimple.com/members
    http://www.reimadesimple.com/elite-wholesaling
    (Don't judge my sales page... it's not meant to be good! I just put it up so people I'm offering a "discount" to (which is everyone) see that the "normal price" is much higher than what they're being offered. My REAL sales pitch is in my autoresponder sequence.)
    {{ DiscussionBoard.errors[8215523].message }}
  • {{ DiscussionBoard.errors[8215639].message }}
  • Profile picture of the author MichaelNz
    the first url loaded very quickly and the last 2 took about 4-5 seconds.
    {{ DiscussionBoard.errors[8215652].message }}
    • Profile picture of the author Matt011
      Originally Posted by Vincent Abrugar View Post

      The pages loaded just fine from my end..
      Originally Posted by MichaelNz View Post

      the first url loaded very quickly and the last 2 took about 4-5 seconds.
      Thanks for the replies. :-)
      {{ DiscussionBoard.errors[8215670].message }}
      • Profile picture of the author Matt011
        Does anyone know if having a lot of themes installed slows down a WP site?
        {{ DiscussionBoard.errors[8215697].message }}
        • Profile picture of the author Matt011
          I found the culprit! It was the plugin WP SlimStat.

          I disabled all my plugins and re-enabled them one by one, as was suggested earlier in this thread, and that one made the site load a lot slower.

          Thanks for the help!

          What's weird though, is that I'm running that same plugin on other sites and it doesn't seem to be slowing anything down... I don't get that, but oh well.
          {{ DiscussionBoard.errors[8215806].message }}
  • Profile picture of the author JaMoke
    Look to be running alright, maybe a little slow (5secs) compared to some other sites

    BTW.. Your PDF image for the first site 25-1 is broken, but the PDF link is Ok
    {{ DiscussionBoard.errors[8216702].message }}

Trending Topics