Register Advertise with usHelp Desk Today's Posts Search

Thread Tools Search this Thread
Unread 23rd Jan 2011, 01:24 PM   #1
New Warrior Member
 
Join Date: 2008
Location: , , USA.
Posts: 9
Thanks: 6
Thanked 4 Times in 4 Posts
Default
Oh Boy... I need help!
Share on: 
fb share twitter share gplus share more share

YIKES!!! I just did an browser compatability view to see what my website would look like
in other browsers and I'm shocked. Most of the browsers show my site to be broken
and everything is out of alignment...Thats not good.

I use IE and my site looks fine but in most other browsers, it looks terrible. Anyone
know how I can fix it so that no matter what browser their using, my site will look good?

Any help would be appreciated, thanks.

dprose55420 is offline   Reply With Quote
Unread 23rd Jan 2011, 07:05 PM   #2
Advanced Warrior
War Room Member
 
wanna-succeed's Avatar
 
Join Date: 2010
Posts: 525
Thanks: 164
Thanked 38 Times in 33 Posts
Default
Re: Oh Boy... I need help!
Share on: 
fb share twitter share gplus share more share

That's something new to my newbish ears....
Why the heck would a site look differently on other browsers?:confused:
I mean, it's the same content, can't they all support it?

No sig, good day m8...
wanna-succeed is offline   Reply With Quote
The Following User Says Thank You to wanna-succeed For This Useful Post:
Unread 23rd Jan 2011, 11:58 PM   #3
Article Marketer
War Room Member
 
Allen Lundy's Avatar
 
Join Date: 2005
Location: Orange, Ca. , USA.
Posts: 559
Thanks: 151
Thanked 270 Times in 184 Posts
Default
Re: Oh Boy... I need help!
Share on: 
fb share twitter share gplus share more share

Hopefully you saved your original Index file or made a back up of your site BEFORE you made the changes.

If so, I would suggest changing your index page back to the original, and then do one change at a time to identify which section you changed is causing the browser mismatch.

I would suspect there's an open or closed <div> </div> that is missing. Hard to say as your source code is a lot different than most PIPS sites.

Also, why do you have TWO end body </body> and end html </html> codes? Again, that's a little strange to me. Not saying it's wrong, but, for me, it looks out of place.

Good luck.

Amazing Deals On Mens and Womens Jewelry - - Gies Jewelry Shop
Watches for all occasions -Gies Watch Shop
The latest in Cameras and Photography - Good Tyme Photography
Need a new phone or upgrade? - Gies Mobile Phones
Number 1 Source For Kids Toys & Games - Shop For Toys & Games
Allen Lundy is offline   Reply With Quote
The Following 2 Users Say Thank You to Allen Lundy For This Useful Post:
Unread 24th Jan 2011, 12:12 AM   #4
HyperActive Warrior
War Room Member
 
jossefsal's Avatar
 
Join Date: 2007
Location: , , Israel.
Posts: 152
Thanks: 0
Thanked 62 Times in 35 Posts
Default
Re: Oh Boy... I need help!
Share on: 
fb share twitter share gplus share more share

Here is what i think happened.

You have an html editor like frontpage, you have build your file with that editor and used copy and past.

In most cases when you copy text, you will copy the style of that text, and the style will change automatically.

Here is what you should do. If you do have the original file, copy your text to notepad first then to your ediror.

IF you do not have the original file.

Re edit the file, save it as another file (oldindex) then reopen the index file, and remove all the content that is making your site wide.

Fix the table that contain width, it must be the same as the header width. I prefer to have all the site on one table that is aligned to the center and have 80% width.

Then copy your text to Notepad and then to your page. It is better to have your text with one font and one size and one color do not mix it.

Link building tips and strategies at SEO Link Building Packages
Best Link Building and Traffic tools online
Best tips opportunities and ways to make money online
jossefsal is offline   Reply With Quote
The Following User Says Thank You to jossefsal For This Useful Post:
Unread 24th Jan 2011, 01:31 AM   #5
HyperActive Warrior
War Room Member
 
WendellC's Avatar
 
Join Date: 2008
Location: Southern California
Posts: 197
Thanks: 12
Thanked 55 Times in 36 Posts
Default
Re: Oh Boy... I need help!
Share on: 
fb share twitter share gplus share more share

Originally Posted by wanna-succeed View Post

That's something new to my newbish ears....
Why the heck would a site look differently on other browsers?:confused:
I mean, it's the same content, can't they all support it?
Hi.

The problem is not really with the content -- it's with the inconsistent way in which browsers interpret the HTML markup.

This is especially true if you use non-validated HTML.

And even when you use validated HTML the browsers can still trip you up because of how they each interpret block and line level spacing.

Yes, it can be quite infuriating having to use workarounds and other quirky adjustments just to make sure the site works in all the major browsers.

And with the rise of mobile devices there is a new class of browsers that need to be taken in consideration.

*sigh*

Wendell

List your no opt-in product here for free: No Opt In Required
WendellC is offline   Reply With Quote
The Following User Says Thank You to WendellC For This Useful Post:
Unread 24th Jan 2011, 01:49 PM   #6
OffTheWallflowerChild
War Room Member
 
Patrician's Avatar
 
Join Date: 2004
Location: USA
Posts: 2,776
Thanks: 6,161
Thanked 2,625 Times in 1,763 Posts
Default
Re: Oh Boy... I need help!
Share on: 
fb share twitter share gplus share more share

Looking at it in Google Chrome browser -

It's okay except for some banners on the left sidebar not displaying - you need to either change the reference link to the image so that the banner will display or consider if it is too wide for the space.

The font you are using in the middle section is way too big in my opinion and it makes the 'marketplace' (your actual PIPS content) look weird since it is in the normal size - it should be centered too - looks funny to be scrunched on the left side.

In FireFox it is a total wreck.

Your little tiny header graphic is 1/4 size of the page - it should go all the way across and would if you didn't use such a huge font.

I like some of the things you are doing that make it unique from other PIPS sites - and I think if you just clear up a few techical issues as mentioned above it will be good.

Patricia Brucoli
Plug-In Profit Site Helpdesk
Patrician is offline   Reply With Quote
The Following User Says Thank You to Patrician For This Useful Post:
Unread 24th Jan 2011, 07:22 PM   #7
Gruntled
War Room Member
 
Roaddog's Avatar
 
Join Date: 2007
Location: On the Border
Posts: 387
Thanks: 1,553
Thanked 1,032 Times in 659 Posts
Default
Re: Oh Boy... I need help!
Share on: 
fb share twitter share gplus share more share

Looked at the source code
I'm no ace coder, but I'd start with both the head tags being closed.

Jim

Roaddog is offline   Reply With Quote
The Following User Says Thank You to Roaddog For This Useful Post:
Unread 25th Jan 2011, 11:20 PM   #8
New Warrior Member
 
Join Date: 2008
Location: , , USA.
Posts: 9
Thanks: 6
Thanked 4 Times in 4 Posts
Default
Re: Oh Boy... I need help!
Share on: 
fb share twitter share gplus share more share

Thank you all very much for the help. I must admit, I lack skills
in the webmaster dept but considering where I started, I'm happy
with what I have learned to this point and it all started with PIP...cool!

Everyone offered great advice and I know every little bit will
help me get back on track. I will get on it and try to get everything
cleaned up quickly as it's driving me crazy knowing it's not perfect.

I use internet explorer and my site looks great to me but all this time it's
been out on the web and it looks like pooh-pooh on most browsers! Geezzzz!

And thanks Pat, it was your post in the tips section that I came
across your tool to check browser compatibility. I'm so glad I checked!

Thank you all again! You guys/gals rock. I'll get to work and clean up the code and make
adjustments. Hopefully I'll get it done before the weekend... Theres fish to be
pulled up through the ice and it's going to be double digit temps this weekend so
we have a heat wave going, hehehe! Should make for a good day on the ice

dprose55420 is offline   Reply With Quote
The Following User Says Thank You to dprose55420 For This Useful Post:


Bookmarks

Tags
boy, browser


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




All times are GMT -6. The time now is 02:13 AM.