Version from PHP 5.6 to PHP 7.1

5 replies
What are the drawbacks during PHP version upgrade (website version from PHP 5.6 to PHP 7.1)

My Question - Any unforeseen disaster on website during the upgrade?
#php #version
Avatar of Unregistered
  • Profile picture of the author DivyaTripathi
    1.One of the advantage of the new PHP 7 is the compelling improvement of performance as compare PHP 5.
    2.PHP 7 performs much faster than PHP 5.6.
    3.To convert the code from PHP 5.6 to PHP ,one needs to check all the compatibility of code and libraries.
    {{ DiscussionBoard.errors[11437146].message }}
  • Whilst this thread is a few months, its content is still very much relevant as PHP 5.6.x is still widely used.

    If it's a script (i.e. WordPress), checking the developer's website to see what the supported versions are is a good start. For more technically savvy people (maybe those who scripted their own site), the migration guide on the official PHP website is an excellent resource.
    Signature

    - Ethernet Servers Limited
    -- SSD cPanel Web Hosting w/ LiteSpeed, MariaDB, CloudLinux & MultiPHP
    --- Dual E5 OpenVZ Virtual Servers w/ KernelCare
    ---- Fully Managed cPanel VPS w/ Softaculous & Daily Backups

    {{ DiscussionBoard.errors[11437208].message }}
  • We did the migration from PHP 5.6 to PHPH 7.X a bit over 1 year ago and have nothing but good words for it. PHP 7 performance is more efficient and faster. We literally saw that our servers consumed less CPU's. Our CPU consumption went from 70% down to 40% or so.

    Migration can take some time, as certain functions need to be rewritten, some libraries are no longer supported natively or as well (e.g. APC) but overall even with those drawbacks definitely worth the migration to PHP7.
    {{ DiscussionBoard.errors[11444283].message }}
  • Profile picture of the author CyberSEO
    If your code is compatible with PHP 7.1, there will be no problems with the upgrade. Otherwise your site just won't work. It's that simple.
    {{ DiscussionBoard.errors[11489692].message }}
  • Profile picture of the author Johnny12345
    I think a lot of people follow the "if it ain't broken, don't fix it" rule.

    I use PHP 5.6 for my tracking scripts. It works fine. Therefore, I see no immediate need to go through the work of updating my code.

    I'll probably wait until I'm forced to update. The truth is, the only reason I'm using 5.6 is because my host forced me to update from 4.3!

    John
    {{ DiscussionBoard.errors[11497753].message }}
Avatar of Unregistered

Trending Topics