Using WP? You might want to check your error logs.

8 replies
I'm using HostGator (not sure if it's limited to their hosting or not) and noticed some huge error log files full of the same line, over and over.

PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-zts-20060613/ixed.5.2.lin' - /usr/local/lib/php/extensions/no-debug-zts-20060613/ixed.5.2.lin: undefined symbol: executor_globals in Unknown on line 0

I put in a support ticket and they said it must be a plugin or something because they couldn't track down the problem, so I deactivated all plugins, deleted the error log file and refreshed the page, it comes right back with the same error.

Switched to default theme, same problem. Upgraded to latest version WP, same problem.

I checked all the domains with Wordpress installed and found this error on every one of them. Some log files were over 25MB.

The sites still load and you may never even know you're having a problem if you don't check the error logs.

I've done some Google research and can't get a clear answer but it looks like it has something to do with something called SourceGuardian, which I've never used and know nothing about.

Anybody else having this issue?
Anyone know what this is?

#check #error #logs
  • Profile picture of the author Bruce Hearder
    Hi Gail..

    I've fust done a qucik look of the bogs I have (I have quite a few) and none of them are showwing huge error files .

    Actually most don't even have an error log at all!

    Do you have any other s/w installed on that same domain that might be causing the error?

    What plugins and theme are you using, maybe there is something hidden in either one that might be causing it..

    I've got a sneaking suspicion that its something to do with the HG server you are one..
    I can't say for certain though..

    {{ DiscussionBoard.errors[450181].message }}
  • Profile picture of the author Gail Sober
    Hey Bruce,

    Thanks for taking a look.

    This may have more to do with the server than anything else. I have several domains, a couple have DLGuard installed, a few are barebones WP installs.

    When searching, I kept running across info for SourceGuardian and a little about cURL & php5, something to do with something needing to be added to the php.ini file in regards to that. Though I do use that on a few domains, I definitely don't use it on all so not sure that would explain it.

    My server was recently upgraded, so maybe that has something to do with it.

    I just logged in through HostGators CP and viewing the error log there shows a couple of things that are totally unrelated to the issue above and only a few lines. (Directory index forbidden by Options directive). (Looks like someones trying to directory surf.)

    Connecting via WS_FTP using -a -l to show hidden files shows me the huge error logs with the repeated error message above. The large error_log files do also show under the CP file manager.

    Guess I'll just completely delete a Wordpress install and upload a static page and see if I can definitely pinpoint WP with this.

    Thanks again Bruce,
    {{ DiscussionBoard.errors[450282].message }}
    • Profile picture of the author Bruce Hearder
      Hi Gail..

      This may seem like a silly question bur what was the last date listed in the error_log?

      Latest errors are generally shown at the top, though not always..

      Maybe the errore curred during their server upgrade and are nothing to stress about at all..

      Try deleting the error_log file (don't worrk its quite safe to do so), and see if the log gets regenerated..

      Let me know how you go..

      Take care

      {{ DiscussionBoard.errors[450292].message }}
  • Profile picture of the author smartsites
    I'm with hostgator and I do not have these errors either.

    I build Facebook Messenger Chatbots and Provide Training. Feel free to check out my demo bot

    {{ DiscussionBoard.errors[450293].message }}
  • Profile picture of the author Gail Sober
    Hey Bruce,

    I've been deleting the error_log files, they are instantly recreated after I refresh the page with current timestamps.

    I uploaded a static html file with text only, refreshed and there was no error.

    I uploaded a static html file from another domain, refreshed and the page displayed with broken images (of course, they were linked like /images and did not exist on that server), the error_log was generated and it showed 14 error lines (same error as the OP above), exactly the number of broken images.

    I edited the html file and used a complete url to the images on the other domain, deleted the error_log file, refreshed and a new error file was not created.

    That makes sense that an error would be generated for a missing file but the code it's showing is perplexing.

    So, it looks like wordpress is trying to include a file from somewhere and it's unable to and throwing that code. This is with the default as well as custom templates (all images show and are sourced correctly) and the admin area.

    Ok, back to figuring this out.

    Thanks guys,
    {{ DiscussionBoard.errors[450541].message }}
    • Profile picture of the author Bruce Hearder
      Hi Gail,

      I have to say I'm running out of ideas here..

      I would suggest downloading a complete new, fresh copy of wordpress from

      Then install this version onto your server.

      Don't install any plugins or anything else, just leave WP as straight out of the box and see what happens..

      If the errors return, then WP is causing the errors, but most likey still a server error.

      Then, if no errors, then upload your template, and see what happens..

      Then the plugins, just one at a time..

      Yes, this is gonna take a while, but this needs to be done to eliminate as many variables as you can to see what is causing it..

      Only then can you fix it..

      Sorry I can't be of any more help

      If this doen't work and HG don't help, then just regularly log in and keep on deleteing those log files..

      Take care

      {{ DiscussionBoard.errors[450587].message }}
  • Profile picture of the author Gail Sober
    Thanks for all of your help Bruce!

    I am 99.99% certain this has to do with SourceGuardian. I've contacted them and am waiting for their response.

    I'll post back if/when I find out what the problem is exactly in case anybody else has this issue now or later.

    {{ DiscussionBoard.errors[450978].message }}
  • Profile picture of the author Gail Sober
    *** SOLVED ***

    After receiving an email from SourceGuardian


    SourceGuardian loaders may not be compatible with custom PHP build. Check if standard PHP is installed on server and check if it is NOT compiled with --enable-versioning option. You may investigate the phpinfo() output for this.

    Also you need to check if the correct version of loader is installed especially "ts" thread safe version if PHP is thread safe and non "ts" version of the loader if PHP is not thread safe.

    I updated my ticket at HostGator with this information and they replied that there was an incorrect entry in php.ini and that they had fixed it.

    Checked and it's working properly now.

    So, if you do notice huge error logs full of the error in the original post, you can ask your host to check your php.ini file to make sure everything is correct there.

    {{ DiscussionBoard.errors[452654].message }}

Trending Topics