BackLink crawling

by Andrew514 17 replies
I have two websites and I am doing backlinking for them, but there is a problem. Google is crawling back links for 1 of the website and indexing them but it is not crawling the back links for the second website. What could be the reason?
#search engine optimization #backlink #crawling
Avatar of Unregistered
  • Profile picture of the author MrMintyBluez
    How are you checking whether or not the links are getting indexed?
    {{ DiscussionBoard.errors[10494997].message }}
    • Profile picture of the author Andrew514
      Originally Posted by MrMintyBluez View Post

      How are you checking whether or not the links are getting indexed?
      I am using "Open Site Explorer" and it is showing just one back link.
      {{ DiscussionBoard.errors[10496729].message }}
  • Profile picture of the author monachus
    Originally Posted by Andrew514 View Post

    I have two websites and I am doing backlinking for them, but there is a problem. Google is crawling back links for 1 of the website and indexing them but it is not crawling the back links for the second website. What could be the reason?
    Is there a chance that you link both your websites from all link sources at the same time? (I mean when you focus on a certain website to get the backlink from, do you always try to get 2 backlinks for your 2 websites?)

    If you do that, stop doing it, because 2 websites with the exact same link profile are not very "natural" in google's eyes, especialy if you manage both websites with the same webmaster tools account.
    Signature
    Aenaos S.A. HVAC engineers and contractors - Thessaloniki - Greece
    {{ DiscussionBoard.errors[10495002].message }}
    • Profile picture of the author Andrew514
      Originally Posted by monachus View Post

      Is there a chance that you link both your websites from all link sources at the same time? (I mean when you focus on a certain website to get the backlink from, do you always try to get 2 backlinks for your 2 websites?)

      If you do that, stop doing it, because 2 websites with the exact same link profile are not very "natural" in google's eyes, especialy if you manage both websites with the same webmaster tools account.
      No I am not doing that, I am using forums to do profile linking. When I put a websites link in profile page, then I sometimes use the second websites link in a forum post otherwise not. So I think it's not the matter.
      {{ DiscussionBoard.errors[10496731].message }}
  • Profile picture of the author thebigweb
    Originally Posted by Andrew514 View Post

    I have two websites and I am doing backlinking for them, but there is a problem. Google is crawling back links for 1 of the website and indexing them but it is not crawling the back links for the second website. What could be the reason?
    Need a bit more info on this to help you OP. Like the other poster said, how do you know they are not being crawled for one site? Do you mean they are not being indexed?
    {{ DiscussionBoard.errors[10495250].message }}
    • Profile picture of the author Andrew514
      Originally Posted by thebigweb View Post

      Need a bit more info on this to help you OP. Like the other poster said, how do you know they are not being crawled for one site? Do you mean they are not being indexed?
      I am using open site explorer. Could any of you guys suggest any good tool for checking indexing of my back links?
      {{ DiscussionBoard.errors[10496744].message }}
      • Profile picture of the author MaxusMumbai
        Originally Posted by Andrew514 View Post

        I am using open site explorer. Could any of you guys suggest any good tool for checking indexing of my back links?
        Opensite explorer reports are not accurate. 1 back link on Opensite Explorer means only back link indexed by Opensite Explorer. Google could have indexed a 100 links.
        {{ DiscussionBoard.errors[10496810].message }}
  • Profile picture of the author mariajerek
    Originally Posted by Andrew514 View Post

    I have two websites and I am doing backlinking for them, but there is a problem. Google is crawling back links for 1 of the website and indexing them but it is not crawling the back links for the second website. What could be the reason?
    Did you checked your backlinks on your webmaster account.
    {{ DiscussionBoard.errors[10496627].message }}
  • Profile picture of the author Andrew514
    When I checked my back links in "Rank Signals" it was showing 109 unique links but after 3 days it is showing 94 unique links. Any help would be appreciated.
    {{ DiscussionBoard.errors[10496798].message }}
  • reminds me of a story. i had one previous client contact me about seo saying she had tried EVERYTHING to get ranked on the search engines but nothing ever happened. If i remember correctly she hired a seo guy from the warrior forum to build links and 4 months later and $4,000 out the window still nothing had changed. When she contacted me about it i asked "what type of website did she use?" She told me "i use wordpress because i heard its the best for seo." I said yeah sort of but do you mind if i take a look at your website files and see if there is a problem i can fix? So she says yes and she gives me her wordpress login information and i go a head and login and so i'm at the main admin page and i was thinking.... "huh, i wonder if she has the hide my website from the search engines check" so i scrolled down and clicked on the settings and ohhhh myy GOD it was checked! The whole time her website was telling google it didn't want to be found!! lol

    the little things in life guys...


    p.s: sorry for the grammar errors. I'm tired and it's way to early for me to be awake
    {{ DiscussionBoard.errors[10496829].message }}
    • Profile picture of the author thebigweb
      Originally Posted by TotalWebsiteControl View Post

      reminds me of a story. i had one previous client contact me about seo saying she had tried EVERYTHING to get ranked on the search engines but nothing ever happened. If i remember correctly she hired a seo guy from the warrior forum to build links and 4 months later and $4,000 out the window still nothing had changed. When she contacted me about it i asked "what type of website did she use?" She told me "i use wordpress because i heard its the best for seo." I said yeah sort of but do you mind if i take a look at your website files and see if there is a problem i can fix? So she says yes and she gives me her wordpress login information and i go a head and login and so i'm at the main admin page and i was thinking.... "huh, i wonder if she has the hide my website from the search engines check" so i scrolled down and clicked on the settings and ohhhh myy GOD it was checked! The whole time her website was telling google it didn't want to be found!! lol

      the little things in life guys...


      p.s: sorry for the grammar errors. I'm tired and it's way to early for me to be awake
      Ouch, bet that hurt when you told her!
      {{ DiscussionBoard.errors[10496838].message }}
    • Profile picture of the author Andrew514
      Originally Posted by TotalWebsiteControl View Post

      reminds me of a story. i had one previous client contact me about seo saying she had tried EVERYTHING to get ranked on the search engines but nothing ever happened. If i remember correctly she hired a seo guy from the warrior forum to build links and 4 months later and $4,000 out the window still nothing had changed. When she contacted me about it i asked "what type of website did she use?" She told me "i use wordpress because i heard its the best for seo." I said yeah sort of but do you mind if i take a look at your website files and see if there is a problem i can fix? So she says yes and she gives me her wordpress login information and i go a head and login and so i'm at the main admin page and i was thinking.... "huh, i wonder if she has the hide my website from the search engines check" so i scrolled down and clicked on the settings and ohhhh myy GOD it was checked! The whole time her website was telling google it didn't want to be found!! lol

      the little things in life guys...


      p.s: sorry for the grammar errors. I'm tired and it's way to early for me to be awake
      Hmm strange but that's not in my case because Google had indexed my sites webpages but not indexing back links. As Rank Signals was showing 109 links 3 days ago and now it is showing only 94 links.
      {{ DiscussionBoard.errors[10496856].message }}
  • Profile picture of the author paladinseo
    try to put ur site on GWT and wait for a few days + it will help if u update ur sites with new content
    {{ DiscussionBoard.errors[10496993].message }}
    • Profile picture of the author Andrew514
      Originally Posted by paladinseo View Post

      try to put ur site on GWT and wait for a few days + it will help if u update ur sites with new content
      Okay, will check it.
      {{ DiscussionBoard.errors[10497655].message }}
  • Profile picture of the author Andrew514
    Waiting for some more suggestions?
    {{ DiscussionBoard.errors[10500459].message }}
Avatar of Unregistered

Trending Topics