Help!! Wordpress "Sorry, but nothing matched your search terms"

by iKirei
6 replies
  • WEB DESIGN
  • |
Hallo ..
is there anyone who can help me solve this problem ..
yesterday I saw this still normal, still shows the article when I click on my post on the homepage ..
but just now when I look again, suddenly it becomes like this

this my post at homepage : Screenshot by Lightshot
but when i click its just showing like this : Screenshot by Lightshot "Sorry, but nothing matched your search terms"

post content : Screenshot by Lightshot

Please help me
#wordpress
  • Profile picture of the author skitblack
    When you do a search it isn't necessary to put the hyphens between the search terms. This will make the search like one big word. Try separating the words with spaces and try again.
    Signature
    Easy to follow WordPress tutorials and tips teach you how to become a blogging success.
    {{ DiscussionBoard.errors[9784972].message }}
  • Profile picture of the author iKirei
    sorry, what do you mean,I do not understand .. I just use wordpress and do not quite understand ..
    Can you give me a screenshot, where I had to fix it .. in search.php or something?
    {{ DiscussionBoard.errors[9785113].message }}
  • Profile picture of the author Patrick
    What exactly did you search for ?

    "Blackberry Vs Iphone" or "Blackberry-vs-Iphone"

    If you had searched for the 1st one, then the post should appear, however if its not appearing, then the search form is coverting your characters to lowercase (which is ok), and then adding a hyphen (-) between the search terms, which is not ok, thats why you see no post in your search results.

    You need to see where the search form is and then see how it is using the search term as, it can be on any file, though most probably it should be on searchform.php

    If it's a paid theme, then contacting the theme author will help.

    Regards.
    {{ DiscussionBoard.errors[9785228].message }}
    • Profile picture of the author iKirei
      Originally Posted by Patrick View Post

      What exactly did you search for ?

      "Blackberry Vs Iphone" or "Blackberry-vs-Iphone"

      If you had searched for the 1st one, then the post should appear, however if its not appearing, then the search form is coverting your characters to lowercase (which is ok), and then adding a hyphen (-) between the search terms, which is not ok, thats why you see no post in your search results.

      You need to see where the search form is and then see how it is using the search term as, it can be on any file, though most probably it should be on searchform.php

      If it's a paid theme, then contacting the theme author will help.

      Regards.
      I'm not using "Search" box..
      I just click link on my homepage : Screenshot by Lightshot..

      i think problem its not on themes, because when i change themes (Tweenty eleven,fourteen) the problem still same..
      {{ DiscussionBoard.errors[9785371].message }}
      • Profile picture of the author Patrick
        Do one thing.

        Go to Settings > Permalink.

        Click on Save Changes.

        And then try to see the post from the home page.

        If you are still unable to see the post, there is something wrong in the anchor link which is linking the heading to the full post.
        {{ DiscussionBoard.errors[9785399].message }}
        • Profile picture of the author iKirei
          Originally Posted by Patrick View Post

          Do one thing.

          Go to Settings > Permalink.

          Click on Save Changes.

          And then try to see the post from the home page.

          If you are still unable to see the post, there is something wrong in the anchor link which is linking the heading to the full post.
          Thanks sir, Thanks you very much ..
          has helped to resolve my problem..

          Solved
          {{ DiscussionBoard.errors[9785455].message }}

Trending Topics