Weird site speed results driving me NUTS

2 replies
  • WEB DESIGN
  • |
Hi, folks! :-)

I have a website speed issue that's driving me NUTS.

We have optimized our WordPress site's speed with things like:

- Using very few plugins
- Using Cloudflare
- Using a caching plugin
- Making some other tweaks here and there.

The site does have quite a few images, which are a necessary evil in this case.

Google PageSpeed Insights gives the site a score of 81% on desktop. But sometimes it also says "NO_FCP".

Pingdom gives a page load speed of 3.34 seconds.

Sometimes, when I visit the site, it loads in 2 seconds.

But others it takes 50+ (fifty plus) seconds!

This is driving me nuts, because results and reports appear to be all over the place.

Is there a reliable way to fix this?

Thanks!
#driving #nuts #results #site #speed #weird
Avatar of Unregistered
  • Profile picture of the author savidge4
    Originally Posted by perneali45 View Post

    Pingdom gives a page load speed of 3.34 seconds.

    Sometimes, when I visit the site, it loads in 2 seconds.

    But others it takes 50+ (fifty plus) seconds!

    This is driving me nuts, because results and reports appear to be all over the place.

    Is there a reliable way to fix this?

    Thanks!
    There is nothing you can "fix" in this. The pipe that is the internet can only handle so much and its kinda at its limits. So fast speed is when less people are on, and slow speeds is when its getting to the point of maxed out.

    hope that at least gives you a better idea of whats going on.
    Signature
    Success is an ACT not an idea
    {{ DiscussionBoard.errors[11597103].message }}
  • Profile picture of the author I V
    your speed is okay, its not bad, if you upgrade to cloud hosting from shared then you'll see much better results
    {{ DiscussionBoard.errors[11598432].message }}
Avatar of Unregistered

Trending Topics