Website doesn''t work with 'WWW'

11 replies
When I use www with my wesite, it doesn't work. I mean not even in Google webmaster tool or browser. But when 'www' is added before 'website.com', it works fine.

My site is 'stylishblinds dot net'.
Urgent help required.
#website #work #www
  • Profile picture of the author jim ken
    Banned
    [DELETED]
    {{ DiscussionBoard.errors[11316395].message }}
    • Profile picture of the author cearionmarie
      Well you see there are just some people who can't get a rest when things are not on how it should be. Like me for example.
      Signature

      Cearion Uy - Marketing Advisor
      www.influencerauditor.com

      {{ DiscussionBoard.errors[11316934].message }}
  • Profile picture of the author smartadset
    Well this is indeed a big deal, I'm sure it's obvious why.

    To OP, This can be caused by DNS, Take a look in your records and see if you have one with "www" that would be the first step. Is it possible to have the domain name because that will help a lot.

    Technical solution : Add both names, with and without the www., to your hosts file, ping them both to make sure they resolve correctly (the box may not reply but the ping program should spit out an IP address), and then navigate to them in a browser and see what happens.

    Let me know how it goes.
    {{ DiscussionBoard.errors[11316588].message }}
    • Profile picture of the author pauloadaoag
      Administrator
      This is the correct answer.
      Signature
      {{ DiscussionBoard.errors[11316827].message }}
    • Profile picture of the author opportunist86
      How to I add both in DNS?
      {{ DiscussionBoard.errors[11316892].message }}
  • Profile picture of the author tritrain
    I suggest that you also look at your .htaccess file, as it may be set up wrong.
    Signature
    Domains for sale - see seopositions.net
    {{ DiscussionBoard.errors[11316614].message }}
  • Profile picture of the author Randall Magwood
    I laughed a few times and i had to read your question a few times before i could understand what you're saying. This is what i'm interpreting:

    Originally Posted by opportunist86 View Post

    When I use www with my wesite, it doesn't work. I mean not even in Google webmaster tool or browser.
    So you mean this?

    www. website .com

    Originally Posted by opportunist86 View Post

    But when 'www' is added before 'website.com', it works fine.
    And you mean this:

    www. website .com

    I dont understand the difference between the 2 conflicts.
    Signature

    {{ DiscussionBoard.errors[11316648].message }}
    • Profile picture of the author opportunist86
      website . com
      www. website . com

      Difference?
      {{ DiscussionBoard.errors[11316893].message }}
  • Profile picture of the author JosephC
    If you are using Bluehost or any other ENG hosting this will happen when you set up the site wrong. Remove the domain, and add it again this time WITHOUT the www. in front of it. Then, when you do use the www, it will automatically redirect
    {{ DiscussionBoard.errors[11316755].message }}
  • Profile picture of the author ChrisBa
    Originally Posted by opportunist86 View Post

    When I use www with my wesite, it doesn't work. I mean not even in Google webmaster tool or browser. But when 'www' is added before 'website.com', it works fine.

    My site is 'stylishblinds dot net'.
    Urgent help required.
    I'm guessing this is likely due to your .htaccess file
    {{ DiscussionBoard.errors[11316840].message }}
  • Profile picture of the author Mr Lim
    .htaccess is probably what you're looking to fix on.
    {{ DiscussionBoard.errors[11317825].message }}
  • Profile picture of the author R0b328
    agree with smartadset and paolo, it's most likely a hosting issue. If you open up a quick support chat with your hosting company it'll most likely be an easy fix and they should be able to walk you through and show you how to fix it in case it happens again in the future
    {{ DiscussionBoard.errors[11317836].message }}

Trending Topics