Search function FIXED!! :)

by Cali16
59 replies
  • OFF TOPIC
  • |
Just thought I'd pass on the good news that the new owners have fixed the search function. Alaister mentioned it in another thread in the Main Discussion Forum (a thread about WSOs, actually), so thought some of you down here in the "basement" (who rarely venture upstairs) might be happy to hear this!
  • Profile picture of the author Alaister
    I know this has been a long ongoing issue. Thank you for everyone's patience.
    Let me know if anyone is still encountering any issues with the search.
    {{ DiscussionBoard.errors[9645704].message }}
    • Profile picture of the author Dennis Gaskill
      Originally Posted by Alaister View Post

      I know this has been a long ongoing issue. Thank you for everyone's patience.
      Let me know if anyone is still encountering any issues with the search.
      I searched for a pot of gold at the end of the rainbow, and couldn't even find the end of the rainbow. Something must be done!
      Signature

      Just when you think you've got it all figured out, someone changes the rules.

      {{ DiscussionBoard.errors[9645828].message }}
      • Profile picture of the author Kay King
        What I don't understand is the absolute silence from management for over a month as many of us reported and asked about the search problem. Questions about whether it would be fixed were not even acknowledged.

        No one expects instant solutions - but knowing tecs are "working on the problem" goes a long way toward feeling someone cares what members think.
        Signature
        Saving one dog will not change the world - but the world changes forever for that one dog.
        ***
        It takes nothing away from a human to be kind to an animal.

        {{ DiscussionBoard.errors[9645872].message }}
    • Profile picture of the author ForumGuru
      Banned
      Originally Posted by Alaister View Post

      I know this has been a long ongoing issue. Thank you for everyone's patience.
      Let me know if anyone is still encountering any issues with the search.
      Big issues...see my previous posts.

      Thanks,

      -don
      {{ DiscussionBoard.errors[9645893].message }}
  • Profile picture of the author ForumGuru
    Banned
    Originally Posted by Cali16 View Post

    Just thought I'd pass on the good news that the new owners have fixed the search function. Alaister mentioned it in another thread in the Main Discussion Forum (a thread about WSOs, actually), so thought some of you down here in the "basement" (who rarely venture upstairs) might be happy to hear this!
    It's not fixed....my "find all posts by user" function only goes back to Aug. 2014... Not even close to being fixed!

    Cheers

    -don
    {{ DiscussionBoard.errors[9645874].message }}
    • Profile picture of the author Cali16
      Originally Posted by ForumGuru View Post

      It's not fixed....my "find posts by user" function only goes back to Aug. 2014... Not even close to being fixed!
      That's weird. Let Alaister know. When I checked mine and a few other random members, everything appeared to be up to date, showing posts from today on back.
      Signature
      If you don't face your fears, the only thing you'll ever see is what's in your comfort zone. ~Anne McClain, astronaut
      {{ DiscussionBoard.errors[9645877].message }}
  • Profile picture of the author ForumGuru
    Banned
    At least yours goes back to 2009 even though you joined in 2007.

    Cheers

    -don
    {{ DiscussionBoard.errors[9645884].message }}
  • Profile picture of the author ForumGuru
    Banned
    I just checked Dennis out....his goes back to only June 2014 for me. (only 633 posts) (4,909 posts according to his profile which of course does not reflect all forum posts)

    http://www.warriorforum.com/search.p...rchid=28126857

    http://www.warriorforum.com/members/dennis-gaskill.html

    I just checked Kay out...hers go back to Aug. 2014 for me. (only 830 posts) (16,583 posts according to her profile which of course does not reflect all forum posts)

    http://www.warriorforum.com/search.p...rchid=28126864

    http://www.warriorforum.com/members/kay-king.html

    I just checked out Alexa...hers go back to Oct. 2014 for me. (only 457 posts) (26,078 posts according to her profile which of course does not reflect all forum posts)

    http://www.warriorforum.com/search.p...rchid=28126930

    http://www.warriorforum.com/members/alexa-smith.html
    {{ DiscussionBoard.errors[9645890].message }}
    • Profile picture of the author Dennis Gaskill
      Originally Posted by ForumGuru View Post

      I just checked Dennis out....his goes back to only June 2014 for me. (only 633 posts)

      I just checked Kay out...hers go back to Aug.2014 for me. (only 830 posts)
      At least it's working for recent posts. That's welcome progress!
      Signature

      Just when you think you've got it all figured out, someone changes the rules.

      {{ DiscussionBoard.errors[9645907].message }}
      • Profile picture of the author positivenegative
        My search function is still fcuked, and has been for months. I've sent PM's to Mods about this, and various other things I asked about, and never even received a courtesy acknowledgement to any of them - let alone a proper response.

        I recall when I first mentioned it in a thread shortly after Freelancer took over . . . and I was shot down by several members who admonished me saying things like, "Give them time", and, "They have many more important things to do than reply to you", or, "I'm sure you'll get a reply in time". I never did.
        {{ DiscussionBoard.errors[9645928].message }}
      • Profile picture of the author Cali16
        Originally Posted by Dennis Gaskill View Post

        At least it's working for recent posts. That's welcome progress!
        This is what I was looking at. I hadn't checked to see how far back anyone's (mine included) posts went (as I thought the real issue was recent posts since end of September were missing). My bad. But, at least they are continuing to work on the issue.
        Signature
        If you don't face your fears, the only thing you'll ever see is what's in your comfort zone. ~Anne McClain, astronaut
        {{ DiscussionBoard.errors[9646047].message }}
        • Profile picture of the author Dennis Gaskill
          Originally Posted by Cali16 View Post

          This is what I was looking at. I hadn't checked to see how far back anyone's (mine included) posts went (as I thought the real issue was recent posts since end of September were missing). My bad. But, at least they are continuing to work on the issue.
          Recent posts are mainly what I use it for, although there are times when going back a ways can be useful. If it just keeps track of things from here on it will be sufficient for most people. The mods probably need the deep search more than anyone, so that could still be fixed at some point.
          Signature

          Just when you think you've got it all figured out, someone changes the rules.

          {{ DiscussionBoard.errors[9646095].message }}
          • Profile picture of the author Cali16
            Originally Posted by Dennis Gaskill View Post

            Recent posts are mainly what I use it for...
            Same here, Dennis. It would be pretty rare for me to want or need to go back several years to check something... But, I suppose that could come in handy at some point.

            Originally Posted by ForumGuru View Post

            At least yours goes back to 2009 even though you joined in 2007.
            It seems to be more about the number of pages back, rather than years / date. I just checked several people's post history. Most seem to go back between 34 and 39 pages - Whateverpedia goes clear to 39 - guess he's special! . Then others seem to go back between only 24 and 26 pages. Strange discrepancy.

            I'm not a prolific poster like some of you, so mine go back much further in terms of months / years, but similar amount of pages.
            Signature
            If you don't face your fears, the only thing you'll ever see is what's in your comfort zone. ~Anne McClain, astronaut
            {{ DiscussionBoard.errors[9646105].message }}
  • Profile picture of the author ForumGuru
    Banned
    Originally Posted by Dennis Gaskill View Post

    At least it's working for recent posts. That's welcome progress!
    Sure it's welcome, but unfortunately it's very little progress, me thinks. The percentage of posts it's returning of Alexa's for me is .01752435002% ---> slightly less than 2%.

    Cheers

    -don
    {{ DiscussionBoard.errors[9645931].message }}
    • Profile picture of the author Alaister
      Thanks for the feedback. We're looking deeper into the issues. It seems as thought more results are appearing however they are not complete.

      Apologies for the lack of communication in regards to this. We will be improving this moving forward and keep everyone updated.
      {{ DiscussionBoard.errors[9645978].message }}
  • Profile picture of the author Paul Myers
    Mine goes back to page 26. Interesting.

    You should point that out to Alaister. That kind of oddity can be very useful in figuring out what's borked and where.


    Paul
    Signature
    .
    Stop by Paul's Pub - my little hangout on Facebook.

    {{ DiscussionBoard.errors[9646134].message }}
    • Profile picture of the author Dennis Gaskill
      Originally Posted by Paul Myers View Post

      Mine goes back to page 26. Interesting.

      You should point that out to Alaister. That kind of oddity can be very useful in figuring out what's borked and where.


      Paul
      Mine goes back 26 pages as well. Don goes back 25 pages. Alaister - sorry, no results found. That Alaister guy is covering his tracks!
      Signature

      Just when you think you've got it all figured out, someone changes the rules.

      {{ DiscussionBoard.errors[9646143].message }}
    • Profile picture of the author ForumGuru
      Banned
      Originally Posted by Paul Myers View Post

      Mine goes back to page 26. Interesting.

      You should point that out to Alaister. That kind of oddity can be very useful in figuring out what's borked and where.

      Paul
      Yeah, I have communicated by PM with Alaister and sent him the actual searches showing the number of pages returned. He told me they will continue to work on it and he apologized the frustration.

      When I was doing the research earlier Alaister's search was returning results from 2009 just like Cali's.

      Cheers

      -don
      {{ DiscussionBoard.errors[9646179].message }}
  • Profile picture of the author Paul Myers
    When I check Alaister's, I get 27 pages. So, not as fixed as it might be...
    Signature
    .
    Stop by Paul's Pub - my little hangout on Facebook.

    {{ DiscussionBoard.errors[9646160].message }}
    • Profile picture of the author Alaister
      Thanks for pointing this out. All this information helps us with putting the puzzle together and better understanding what's causing the issue.

      Thank you
      {{ DiscussionBoard.errors[9646175].message }}
    • Profile picture of the author Dennis Gaskill
      Originally Posted by Paul Myers View Post

      When I check Alaister's, I get 27 pages. So, not as fixed as it might be...
      Tried it again after your comment and I got 27 pages this time. And he thought he could hide from us!
      Signature

      Just when you think you've got it all figured out, someone changes the rules.

      {{ DiscussionBoard.errors[9646183].message }}
  • Profile picture of the author Paul Myers
    Don,

    When I checked using the links in your other post, I got no results. When I checked using the menu option under the same members' names, I got the post histories. Maybe another clue?


    Paul
    Signature
    .
    Stop by Paul's Pub - my little hangout on Facebook.

    {{ DiscussionBoard.errors[9646182].message }}
    • Profile picture of the author ForumGuru
      Banned
      Originally Posted by Paul Myers View Post

      Don,

      When I checked using the links in your other post, I got no results. When I checked using the menu option under the same members' names, I got the post histories. Maybe another clue?

      Paul
      Good call....yeah, those links are dead for me now as well. I did not use the insert link function when I posted them either.

      Testing Dennis again...this time with the insert link button.

      http://www.warriorforum.com/search.p...rchid=28128216

      And it seems to work...

      Do you remember if those links go dead after a new post is added by the user? I guess we will find out something when Dennis makes another post.
      {{ DiscussionBoard.errors[9646189].message }}
      • Profile picture of the author Dennis Gaskill
        Originally Posted by ForumGuru View Post


        Do you remember if those links go dead after a new post is added by the user? I guess we will find out something when Dennis makes another post.
        I'm off to bed, but here's the post you were waiting for.
        Signature

        Just when you think you've got it all figured out, someone changes the rules.

        {{ DiscussionBoard.errors[9646281].message }}
        • Profile picture of the author ForumGuru
          Banned
          Originally Posted by Dennis Gaskill View Post

          I'm off to bed, but here's the post you were waiting for.
          Thanks,

          That link still works for me it just does not show the reply you just posted and I am almost certain that's how it used to work.

          I don't know why the link is not working for Paul.
          {{ DiscussionBoard.errors[9646291].message }}
  • Profile picture of the author Paul Myers
    Don,

    Worked from the menu and not from the link. Wonder what's up with that?


    Paul
    Signature
    .
    Stop by Paul's Pub - my little hangout on Facebook.

    {{ DiscussionBoard.errors[9646192].message }}
    • Profile picture of the author ForumGuru
      Banned
      Originally Posted by Paul Myers View Post

      Don,

      Worked from the menu and not from the link. Wonder what's up with that?

      Paul
      Does that most recent link I posted work for you? Or is that the one to which you just reffered?
      {{ DiscussionBoard.errors[9646199].message }}
  • Profile picture of the author ForumGuru
    Banned
    As far as page count's goes --> Alexa's only goes back 19 pages.
    {{ DiscussionBoard.errors[9646196].message }}
  • Profile picture of the author Paul Myers
    Don,

    That's the one I meant. The new one doesn't work for me either, from the post. Still works from the menu under his name, though.


    Paul
    Signature
    .
    Stop by Paul's Pub - my little hangout on Facebook.

    {{ DiscussionBoard.errors[9646201].message }}
    • Profile picture of the author ForumGuru
      Banned
      Originally Posted by Paul Myers View Post

      Don,

      That's the one I meant. The new one doesn't work for me either, from the post. Still works from the menu under his name, though.

      Paul
      Weird...it work's for me, even in a new browser I just opened. This is a very strange issue indeed. Holy smokes....
      {{ DiscussionBoard.errors[9646211].message }}
  • Profile picture of the author ForumGuru
    Banned
    As far as 2009 goes I just checked Suzanne's "thanked posts" and while almost 5000 results are returned the search does not return results beyond 2009.
    {{ DiscussionBoard.errors[9646217].message }}
  • Profile picture of the author Paul Myers
    I get the same results in Explorer that I got in Firefox. Works from the menu, doesn't from the link.


    Paul
    Signature
    .
    Stop by Paul's Pub - my little hangout on Facebook.

    {{ DiscussionBoard.errors[9646220].message }}
  • Profile picture of the author Paul Myers
    The Thanks option wasn't added until, if memory serves, September of 2008. It wasn't used a lot early on, so that may be all the results there are to show.

    Edited to add: I'm wrong. It was August of 2008.

    And another edit: Hmmm. It shows 4300 of mine, which is less than the profile shows. But, the difference would be about the number of admin-related posts of mine that got deleted when Allen went on a clean-up spree of those once.

    That might be the reason for the discrepancy, if the system doesn't remove thanks for deleted posts over X days old.
    Signature
    .
    Stop by Paul's Pub - my little hangout on Facebook.

    {{ DiscussionBoard.errors[9646224].message }}
  • Profile picture of the author ForumGuru
    Banned
    These symptoms are almost a real mystery... I just logged out, cleared my browser data, reopened my browser, logged back in and that link is still working for me even in Chrome.
    {{ DiscussionBoard.errors[9646259].message }}
  • Profile picture of the author ForumGuru
    Banned
    Does that url look like this to you? I suppose it must...

    Code:
    http://www.warriorforum.com/search.php?searchid=28128216
    What does the url look like when you access the results from the menu?

    It returns this for me from the menu:

    Code:
    http://www.warriorforum.com/search.php?searchid=28128524
    {{ DiscussionBoard.errors[9646265].message }}
  • Profile picture of the author Paul Myers
    Same URL each time. I checked that early on, in case it was a syntax issue.

    BTW, copying and pasting that in didn't work either. Seems only to work from the menu.
    Signature
    .
    Stop by Paul's Pub - my little hangout on Facebook.

    {{ DiscussionBoard.errors[9646269].message }}
  • Profile picture of the author ForumGuru
    Banned
    Can you copy and paste either of those I just posted in the code boxes and get to the results?
    {{ DiscussionBoard.errors[9646273].message }}
  • Profile picture of the author Paul Myers
    Ooops. Wrong.

    From the menu, it's:
    Code:
    http://www.warriorforum.com/search.php?do=finduser&u=491803
    It redirects to that same link each time, which is why I didn't notice it.
    Signature
    .
    Stop by Paul's Pub - my little hangout on Facebook.

    {{ DiscussionBoard.errors[9646275].message }}
  • Profile picture of the author ForumGuru
    Banned
    What? I am not getting redirects either way....I am getting what I posted in the most recent code boxes.
    {{ DiscussionBoard.errors[9646283].message }}
  • Profile picture of the author Paul Myers
    If you hover over the menu option, you can see the actual link at the bottom of the browser if you have that enabled. Or just do that and "Copy Link Location."
    Signature
    .
    Stop by Paul's Pub - my little hangout on Facebook.

    {{ DiscussionBoard.errors[9646290].message }}
  • Profile picture of the author ForumGuru
    Banned
    I got you now, I was missing that quick redirect. This is what I am seeing from the menu for Dennis which I am sure is what you are seeing.

    Code:
    http://www.warriorforum.com/search.php?do=finduser&u=70702
    {{ DiscussionBoard.errors[9646297].message }}
  • Profile picture of the author Paul Myers
    70702 is Dennis' user number.

    Ahhhhh... DOH!

    Maybe searchid is a user-specific thing? That would explain why those links work for you and not me (or probably anyone else).

    Except, I don't think they're supposed to be user-specific.
    Signature
    .
    Stop by Paul's Pub - my little hangout on Facebook.

    {{ DiscussionBoard.errors[9646301].message }}
    • Profile picture of the author ForumGuru
      Banned
      Originally Posted by Paul Myers View Post

      Maybe searchid is a user-specific thing? That would explain why those links work for you and not me (or probably anyone else).

      Except, I don't think they're supposed to be user-specific.
      Nah, I don't think so either. I have seen (clicked on) and posted search strings to the past and they have worked fine. Post one of yours in the format I did and let me see if I can get to it.
      {{ DiscussionBoard.errors[9646304].message }}
  • Profile picture of the author ForumGuru
    Banned
    These still don't work?

    Code:
    http://www.warriorforum.com/search.php?searchid=28128524
    
    http://www.warriorforum.com/search.php?searchid=28128216
    How about Cali?

    http://www.warriorforum.com/search.p...rchid=28128614

    Code:
    http://www.warriorforum.com/search.php?searchid=28128614
    {{ DiscussionBoard.errors[9646303].message }}
  • Profile picture of the author Paul Myers
    Nope. And I don't think they will. That appears to be a settings issue, not an artifact of any problem with the new search function.
    Signature
    .
    Stop by Paul's Pub - my little hangout on Facebook.

    {{ DiscussionBoard.errors[9646305].message }}
  • Profile picture of the author Paul Myers
    Code:
    http://www.warriorforum.com/search.php?searchid=28128638
    Signature
    .
    Stop by Paul's Pub - my little hangout on Facebook.

    {{ DiscussionBoard.errors[9646306].message }}
  • Profile picture of the author ForumGuru
    Banned
    Yep, user specific at this point.
    {{ DiscussionBoard.errors[9646311].message }}
  • Profile picture of the author ForumGuru
    Banned
    Try this general search --> I know these used to work in the past. This is search for "photos" forum wide.

    Code:
    http://www.warriorforum.com/search.php?searchid=28128666
    It may not work for you and it used to work. I think the URL now is much different than what the search string used to be.
    {{ DiscussionBoard.errors[9646313].message }}
  • Profile picture of the author Paul Myers
    Try this one. Let's see if a different type of search works:

    http://www.warriorforum.com/search.p...rchid=28128676
    Signature
    .
    Stop by Paul's Pub - my little hangout on Facebook.

    {{ DiscussionBoard.errors[9646314].message }}
  • Profile picture of the author Paul Myers
    Both had the same idea. And yes, that one worked.
    Signature
    .
    Stop by Paul's Pub - my little hangout on Facebook.

    {{ DiscussionBoard.errors[9646315].message }}
  • Profile picture of the author ForumGuru
    Banned
    Typing at the same time and thinking the same way now...

    So the format supposedly can work, but for some reason it's not on the find post by user function --> at least between you and I and most likely others.
    {{ DiscussionBoard.errors[9646318].message }}
  • Profile picture of the author Paul Myers
    I suspect it's limited by the type of search. I don't recall that ever being the case before, but I might not have seen this type of search posted.
    Signature
    .
    Stop by Paul's Pub - my little hangout on Facebook.

    {{ DiscussionBoard.errors[9646319].message }}
  • Profile picture of the author ForumGuru
    Banned
    As far as that 24, 25, 26 page thing goes it's really sporadic.

    The Niche man is showing 39 pages...

    http://www.warriorforum.com/search.p...rchid=28128717

    View Profile: The Niche Man



    It seems like some sort of multiple copy, possibly cache, never "indexing" everything type of issue.
    {{ DiscussionBoard.errors[9646325].message }}
  • Profile picture of the author Paul Myers
    I theorized months ago that a big chunk of the search problems was that it was looking at two copies of the database, and somehow alternating between them.

    It makes sense, but I don't know enough about the system to be sure that's it.
    Signature
    .
    Stop by Paul's Pub - my little hangout on Facebook.

    {{ DiscussionBoard.errors[9646336].message }}
    • Profile picture of the author ForumGuru
      Banned
      Originally Posted by Paul Myers View Post

      I theorized months ago that a big chunk of the search problems was that it was looking at two copies of the database, and somehow alternating between them.

      It makes sense, but I don't know enough about the system to be sure that's it.
      Yeah, me either. It seems no matter how many copies they have for quite sometime they have not been returning the older posts for the majority of the users...many, many months in my case, and I have been checking virtually every day for months.

      Whatever is happening it appears that none of the DB copies have complete results. I don't have any fancy or complex DB installs or disk arrays (and never have had) so it's beyond me as well.

      Re: Page count --> Except the person that has the most posts on the forum only returns 19 pages. So strange. I have checked out quite a few users and several have had 39 pages but that's as high as I have seen. I am not even sure if it tells us much other than we have not seen over 39 pages returned on these types of searches.

      Unfortunately, we aren't making a great deal of headway here...
      {{ DiscussionBoard.errors[9646355].message }}
  • {{ DiscussionBoard.errors[9646342].message }}
  • Profile picture of the author Paul Myers
    The first two links don't work. You could get a working link by copying it from the menu.

    It does seem to be in the 24-27 and 35-39 range. Pretty much as Cali mentioned.
    Signature
    .
    Stop by Paul's Pub - my little hangout on Facebook.

    {{ DiscussionBoard.errors[9646350].message }}
  • Profile picture of the author sbucciarel
    Banned
    I'm happy with the improvement ... works for recent results, which is what I am mostly interested in anyway. Doesn't pick up everything, but it's rare that I would go past a few hundred posts to look for something.
    {{ DiscussionBoard.errors[9646887].message }}

Trending Topics