Setting File Permissions Issue

8 replies
I'm having serious issues with setting file permissions on my server. I didn't even know a thing about permissions and 666/777 and all that stuff until today when I started installing some plugins on my blog and had to deal with changes permissions.

Like I tried installing WP Super Cache and got a message saying my content folder of WP is writable, saying :
You should change the permissions on D:\Hosting\(myinfo) and make it more restrictive. Use your ftp client, or the following command to fix things:chmod 755 D:\Hosting\(myinfo).

I tried changing the permissions in both Dreamweaver 8, through my hosting provider, and with FileZilla, as well. Dreamweaver said "setting access properties failed for: (mysite)" and FileZilla was saying "command not understood". I'm not even sure what the permissions are set to as of right now. I assume it's a 777 which I've read is a massive security risk.

I know this post is a bit open ended but I really am daft when it comes to this so if someone who is better informed could give me some helpful advice I would really appreciate it. Thanks.
#file #issue #permissions #setting
  • Profile picture of the author badwolf
    In Filezilla, you should right-click on the directory or file on the remote site (shown in the right-hand pane) and select file permissions from the menu that pops up. In the file permissions dialog, just check or uncheck the permissions you want to set/unset. Then click the OK button and let Filezilla do the rest.
    Signature
    www.videocardroundup.com -- news/views/tutorials for all things related to PC video/graphics cards
    www.peonyplants.net -- the gorgeous world of peonies
    {{ DiscussionBoard.errors[2986156].message }}
  • Profile picture of the author Neil Morgan
    The paths you mention (eg d:\ whatever) suggest you're on a Windows server.

    But file and directory permissions (777, 755 etc) are Linux only and do not apply to Windows so that explains the "command not understood" error.

    Cheers,

    Neil
    Signature

    Easy email marketing automation without moving your lists.

    {{ DiscussionBoard.errors[2986561].message }}
  • Profile picture of the author mywebwork
    Neil has nailed it - you're trying to execute LINUX commands on a Windows server. Your instructions assumed that you had a LINUX server, which is by far the most common type.

    Although this article pertains to Joomla it does do a decent job of equating LINUX and Windows file permissions:

    Joomla and Windows file permissions - Explanation

    Bill
    {{ DiscussionBoard.errors[2986711].message }}
  • Profile picture of the author CrhisD
    Why would anyone use a Windows server?
    {{ DiscussionBoard.errors[2987451].message }}
  • Profile picture of the author trentonlaura
    Ah that would make sense then. I also didn't know Linus was the most common. I don't remember what I did when I signed up for hosting but I do see I have windows shared hosting. Is there a specific way to set permissions for Windows hosting then or do I not have anything to worry about in the first place?
    {{ DiscussionBoard.errors[2991426].message }}
  • Profile picture of the author kkoechel
    it's easy to fix if you use putty or some sort of terminal software to get you there.

    putty is free: PuTTY Download Page
    {{ DiscussionBoard.errors[2991492].message }}
  • Profile picture of the author kkoechel
    linux rules windows droolz: Linux versus Windows
    {{ DiscussionBoard.errors[2991551].message }}

Trending Topics