Amazon S3 Help Needed - PLEASE -

by Aarron
7 replies
Hey there,

My Apologies In Advance If This Is The Wrong Place To Put This Thread!

I have tried EVERYTHING and I am having this problem and it is starting to really stress me out, I was hoping to have this all sorted asap because I want to get the ball rolling on things I am trying to do at the moment.

If anyone else can help I would really appreciate it too!

I tried what you suggested and went over to the link you left for me - thanks for that by the way.

However I went through everything and it appears I have done everything correctly, this is really frustrating now!!!

The error I get is this:

Javascript Application

The request signature we calculated does not match the signature you provided. Check your key and signing method.

I really would LOVE anyone to help if they can before I lose my mind.

#amazon #needed
  • Profile picture of the author Jim Westergren
    You really have to specify more details. What are you using and how and where do you get that error? Are you using a PHP class and if so which one? Did you enter the key correctly?

    Jim Westergren | TodaysWeb

    {{ DiscussionBoard.errors[3552944].message }}
  • Profile picture of the author Aarron
    Hey Jim,

    Basically the error above pops up every time I open up S3Fox or CloudBerry, without me actually doing anything. It's as soon as I open up either of those two programs.

    I've been into the AW website got my Access ID and Security Key ( I typed them in manually too so ther were no added spaces etc)

    I added a bucket via the Amazon S3 console. But I cannot get any further than that as the error pops up when I open the two stated programs I've been trying to use with it.

    Thanks again
    {{ DiscussionBoard.errors[3553532].message }}
  • Profile picture of the author PaulChester
    Hi ramshanked,

    It sounds like you've added the keys in the wrong places - make sure you don't get your access key and secret keys mixed up. If you login on this page:

    You can see your access key (under the "access key id" column) and then click on "show" - under "secret access key". Make sure you put these two values in the right place. Sorry if that sounds patronising but I know I've got it wrong a few times on s3fox - though I don't remember seeing the error you mention.

    Failing that are you aware of the aws console: AWS Management Console can do most of what s3fox and cloudberry do - it's just not as streamlined. You can upload files to s3, manage permissions etc - it didn't used to be great for bulk file uploads but that may have changed.

    Hope that helps,
    {{ DiscussionBoard.errors[3558769].message }}
  • Profile picture of the author Aarron
    Hey Paul,

    Tried trying the keys again but same problem, I have even tried uninstalling the software and downloading it all over again, but I am still getting the same problem. It's strange that I can't get this resolved, I'd rather use this than an alternative but at the moment I am leaning towards an alternative because I have asked on a couple of forums but I'm gettin nothing new from any of them either.

    I'm not sure how to reslove this but if someone can then I would be obviously over the moon. How would I check my clock time? I've been told that could be the issue but I'm pretty sure it is spot on because everything else works (other programs unrelated to the aws s3 program).

    Im not sure why it is a Javascript application issue either, because I have not added any files or code to the s3 program, nothing is on there.

    I have tried as many different consoles as I can but I'm getting the same error each time. I'm at a loss now, S3Fox wont work, Cloudberry won't work, none that I have tried will work.

    I'm clueless now - completely stumped.
    {{ DiscussionBoard.errors[3594154].message }}
  • Profile picture of the author Paleochora
    Try updating Firefox if you are running an older version. Maybe that your S3Fox is made for a later version of FF and is not backwards compatible with your version?
    {{ DiscussionBoard.errors[3594299].message }}
  • Profile picture of the author Jesus Perez
    How are you copy/pasting your keys? If you're bringing in spaces, it'll break the key and cause this problem. Double check what you're pasting using notepad. Make sure it matches up and isn't inserting spaces before or after.

    {{ DiscussionBoard.errors[3594668].message }}
  • Profile picture of the author Aarron
    Hey guys thanks for your

    paleochora: I have updated the firefox browser and the S3Fox program and same problem but thank you for the advice - appreciate it!

    Jesus Perez: I've been manually typing them in as well as using notepad to copy and paste them to make sur there were no additional spaces however this has not solved the issue either - thanks for your advice too though !
    {{ DiscussionBoard.errors[3595183].message }}

Trending Topics