6 replies
I purchased the WP amazing plugin designed to create automated amazon stores. After I created the blog, I proceeded to upload the plugin for installation. when I pressed the install now button the following error appeared:
Unable to create directory /home/myusername/public_html/folder with wp/wp-content/uploads/2011/10. Is its parent directory writable by the server?
I tried to install it on wordpress 321 and 312 but got the same results. Help is needed and will be highly appreciated. Thanks all:confused:
#error #wordpress
  • Profile picture of the author kdavies
    You just need to make the directory that it's trying to write to, writable.

    http://www.warriorforum.com/warriors...rogrammer.html

    Kind regards

    Kevin
    {{ DiscussionBoard.errors[4889121].message }}
  • Profile picture of the author lordspace
    do chmod 777 to /home/myusername/public_html/folder with wp/wp-content/uploads

    either through your FTP client or SSH.
    I think FTP should be easier for you.

    you probably haven't uploaded a file yet, correct?
    Signature

    Are you using WordPress? Have you tried qSandbox yet?

    {{ DiscussionBoard.errors[4892033].message }}
    • Profile picture of the author vServer Center
      Originally Posted by lordspace View Post

      do chmod 777 to /home/myusername/public_html/folder with wp/wp-content/uploads
      Yes, your problem is a file permission problem.
      But set permission to 777 makes it wide open to everyone.
      I suggest you set the permission only writable by the web server user. On most servers, it is a user called: apache
      It is more secure this way.
      {{ DiscussionBoard.errors[4894811].message }}
  • Profile picture of the author murrad
    This problem can be of any reason. I had similar problem and I turned the PHP safe mode off and it worked well. But it seems many bloggers face this issue.
    Signature

    Environment friendly Paper cup machine

    {{ DiscussionBoard.errors[4892517].message }}
  • Profile picture of the author JannuBl22t
    It's very simple error. Wordpress is not allowed to write files inside the "uploads" folder. Fix for it is very simple. Las Lordspace told you, you have to change that folder's permissions to read, write, execute for everybody which means 0777 or just 777. You can change those permissions in your FTP software or logging to SSH console like Putty and write:

    chmod 777 /path/to/your/folder
    I hope it helps !
    Signature
    Priority Prospect's Cloud PBN Hosting
    True Cloud Hosting - Dedicated IPs, cPanel and much more!
    {{ DiscussionBoard.errors[4893370].message }}
  • Profile picture of the author SupporTech
    I had the same problems before, but please create this kind of Folders:
    /uploads/2011/10

    Manually create that folders so that you can upload it, but the easiest way is:
    If your using windows, and you have an Xampp, please:
    Upload it in your localhost wordpress after u uploaded it, track the folder of plugin, copy it, and paste it in the plugins folder of your Online Site using the FTP!
    {{ DiscussionBoard.errors[4895039].message }}

Trending Topics