Did My Site Get Hacked?

by Bon508
10 replies
This is what I'm getting when I try to view my WordPress site, Kettlebell-Swings.com:

Warning: require(/home/xxx/public_html/KETTLEBELL-SWINGS.COM/wp-includes/capabilities.php) [function.require]: failed to open stream: No such file or directory in /home/xxx/public_html/KETTLEBELL-SWINGS.COM/wp-settings.php on line 113

Fatal error: require() [function.require]: Failed opening required '/home/xxx/public_html/KETTLEBELL-SWINGS.COM/wp-includes/capabilities.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/xxx/public_html/KETTLEBELL-SWINGS.COM/wp-settings.php on line 113
(I've changed the path slightly with the "xxx")

I have no idea what any of that means. I am not a programmer, nor do I play one on the Internet.

Did my site get hacked or something? :confused:

Can anyone translate that into Blonde for me, and -- more importantly -- help me fix it?
#hacked #site
  • Profile picture of the author Michael Wood
    I don't know much about programming websites, but I do know of a company where programmers are ready and willing to help you. Have you every heard of fiverr.com? Go to fiverr type in programmer in the search bar and you'll find hundreds of programmers. It will only cost you five dollars. I hope everything works out for you.

    -Michael
    Signature

    Read the forum rules.

    {{ DiscussionBoard.errors[6453423].message }}
  • Profile picture of the author seopress
    Bonnie,
    Looks like for whatever reason, one of the core wordpress files ( /wp-includes/capabilities.php ) is missing from your installation. There may be other missing files, so my recommendation would be to re-upload the entire /wp-includes folder, overwriting all existing files.

    Regards,
    Dave
    SEOPressReleases.com
    Signature
    SEOPressReleases
    Your News on Over 75 Media Partner Web Sites
    {{ DiscussionBoard.errors[6453758].message }}
  • Profile picture of the author goosefrabah
    Originally Posted by Bon508 View Post

    This is what I'm getting when I try to view my WordPress site, Kettlebell-Swings.com:



    (I've changed the path slightly with the "xxx")

    I have no idea what any of that means. I am not a programmer, nor do I play one on the Internet.

    Did my site get hacked or something? :confused:

    Can anyone translate that into Blonde for me, and -- more importantly -- help me fix it?
    This can happen for two reasons.

    1. The files were some how deleted or renamed.
    2. The file exists, but does not have the appropriate permissions.
    {{ DiscussionBoard.errors[6453987].message }}
  • Profile picture of the author Bon508
    re-upload the entire /wp-includes folder
    Hey Dave, how would I do that? Re-upload that folder from where? Could I copy it from a different WordPress site?

    Michael, thanks for the tip about fiverr. I have used fiverr before, but didn't think about it for this problem. I'll go take a look.

    Goose... I think it's #1 -- I can't find the capabilities.php file; it must've been deleted somehow. Gremlins?

    Thank you all!
    Signature
    {{ DiscussionBoard.errors[6457049].message }}
  • Profile picture of the author ratnad3w1
    the easiest way is reinstall it
    {{ DiscussionBoard.errors[6457248].message }}
  • Profile picture of the author topnichewebsites
    Sent you a PM on what to do. If you need additional help let me know. We can fix it pretty quick.
    Signature
    http://pixelcovers.com/ <- eBook add eCovers

    https://www.unicommercesolutions.com <- WordPress Websites and Maintenance
    {{ DiscussionBoard.errors[6457447].message }}
  • Profile picture of the author JezWebb
    Yep, SEOpress is right, but I wonder where it went!? I'd maybe also ask topnichewebsites to find an answer to that.

    WordPress has improved a lot in terms of helping with maintenance. There is now a "Reinstall Now" button.
    Signature

    Web strategist and adventurer. Director of Search Engine Friendly Hosting. ---Fast, affordable, feature packed hosting from £1.97. --- Search Engine Friendly Web Hosting

    [VIDEO] How to set up a WordPress blog in under 10 minutes.

    {{ DiscussionBoard.errors[6465058].message }}
    • Profile picture of the author Bon508
      Originally Posted by topnichewebsites View Post

      Sent you a PM on what to do. If you need additional help let me know. We can fix it pretty quick.
      Thank you so much, Michael! I know you explained very clearly what needed to be done, but if I'd tried to do it myself, I'd still be working on it (and pulling out my hair in frustration) for the next year or so!

      You got my site back up in no time (within just a few minutes!) -- "YAY!"

      I really appreciate your help.

      I've got your contact info stashed away for safekeeping and will reach out again when (not if) I need help again. Programming and I don't play well together, so your talents are definitely going to come in handy.

      Thanks again -- and thanks to the others who offered help in this thread, as well!
      Signature
      {{ DiscussionBoard.errors[6465494].message }}
  • If you have installed the site via fantastico or autoinstaller, try manual upload method via FTP. It may work.
    Signature
    {{ DiscussionBoard.errors[6467057].message }}
  • Profile picture of the author topnichewebsites
    Glad we could help you out and got both of your sites back online.
    Signature
    http://pixelcovers.com/ <- eBook add eCovers

    https://www.unicommercesolutions.com <- WordPress Websites and Maintenance
    {{ DiscussionBoard.errors[6467168].message }}

Trending Topics