M.Samurai - fetching keywords problem

by leven
17 replies
  • SEO
  • |
Hello everyone - very new at this. I have Market Samurai (which is frustratingly slow but ok for a newbie like me) - it was working fine then my pc had heart failure - complete reload later - now samurai is not working - I can create a keyword no problem but when I try to generate keywords the fetch stage just never finishes - goes over 100%.

Can somebody please explain what I have done wrong? :confused:
#fetching #keywords #msamurai #problem
  • Profile picture of the author Jamie Lin
    Hello,

    You might have slow internet connection, this can be fixed by adjusting connection timeout on File -> Settings

    See the picture below:
    hxxp://i.imgur.com/LTQCR.jpg

    Lower the settings and see if this resolves your problem.
    {{ DiscussionBoard.errors[5700306].message }}
    • Profile picture of the author leven
      Hi Jamie Lin. Thank you for your suggestion. Unfortunately it didn't make any difference.
      {{ DiscussionBoard.errors[5700535].message }}
  • Profile picture of the author jenn1
    I will be interested to hear how you like Market Samurai...I have been considering getting this. Everything I have read has been positive.

    Sorry I can't help with your other problem
    Signature
    This Music Makes You Smarter
    www.BrainwaveAndCrystals.com
    {{ DiscussionBoard.errors[5700309].message }}
    • Profile picture of the author salegurus
      Originally Posted by jenn1 View Post

      I will be interested to hear how you like Market Samurai...I have been considering getting this. Everything I have read has been positive.

      Sorry I can't help with your other problem
      MS has been one of the best investments iv'e made as far as IM tools go.
      I got it about 3 years ago and have had great success with it.
      Unfortunately recent "problems" have IMO devalued MS a bit and it's not nearly as powerful as it was in the past.

      Eugene, Alex and the rest of the MS dev team have been great when it comes to keeping MS updated and sorting problems, hopefully they will get it back to where it was...
      Signature
      Think of how stupid the average person is, and realize half of them are stupider than that.

      ― George Carlin
      {{ DiscussionBoard.errors[5700396].message }}
    • Originally Posted by jenn1 View Post

      I will be interested to hear how you like Market Samurai...I have been considering getting this. Everything I have read has been positive.

      Sorry I can't help with your other problem
      It's still a decent tool, but it's not as good as it was a year ago. They seem to have continual issues like this.

      To be honest I usually just use the free google keyword tool now.
      {{ DiscussionBoard.errors[5705171].message }}
  • Profile picture of the author outwest
    DONT use MS to find kws
    I have had it for 6 mos
    Sure I can use it for that but its notoriously slow for that.............it uses Google kw database anyways. so why not use Google ADWORDs tool, instead? its 100 x faster than MS

    I use MS only for analyzing Google top 10 competion for that its amazing, and FAST
    takes about 15 secs per kw
    Signature
    Tech article writing .Native English Speaker(with Proof)
    specializing in SmartPhones , Internet security, high tech gadgets, search engines, tech shows, digital cameras.

    {{ DiscussionBoard.errors[5700547].message }}
    • Profile picture of the author leven
      hi outwest - thank you for your post. I do use adwords too - but is not the point. This MS is not working at all - the fetch just never finishes while the % just keeps climbing - I've had it up to 257% - I've uninstalled it and reinstalled it and even tried a new account (that didn't work) - it just wont work. I don't understand if the problem is with the ms program or maybe at the Google end of things - it is just very frustrating and I would like to know why this has happened.
      {{ DiscussionBoard.errors[5700670].message }}
      • Profile picture of the author outwest
        Originally Posted by leven View Post

        hi outwest - thank you for your post. I do use adwords too - but is not the point. This MS is not working at all - the fetch just never finishes while the % just keeps climbing - I've had it up to 257% - I've uninstalled it and reinstalled it and even tried a new account (that didn't work) - it just wont work. I don't understand if the problem is with the ms program or maybe at the Google end of things - it is just very frustrating and I would like to know why this has happened.
        MS has lots of issues lately
        I have never gotten the find a kw function to work properly or fast enough
        just look at it for what it is, its kind of a scraper that google dislikes

        use it for what it does best. and ignore the rest
        the top 10 analyzer SEO function is well worth the price you pay
        Signature
        Tech article writing .Native English Speaker(with Proof)
        specializing in SmartPhones , Internet security, high tech gadgets, search engines, tech shows, digital cameras.

        {{ DiscussionBoard.errors[5700699].message }}
  • Profile picture of the author ktonline
    I have been using Market Samurai for a long time and I found it to be very useful. It does a good job at doing a proper keyword research and SEO Comp. Only problem is that whenever Google changes its algorithm it does have trouble getting data.
    {{ DiscussionBoard.errors[5701098].message }}
  • Profile picture of the author aktommy
    I am having the same issues since the last update. All progress is extremely slow and goes over 100 percent, never loads the results. At this point MS is non functioning at all on my system. Everything worked great 4 days ago before this update.
    {{ DiscussionBoard.errors[5701976].message }}
  • Profile picture of the author jsmith2482
    Is MS really that much more effective for finding keywords then google's keyword tool?
    {{ DiscussionBoard.errors[5702009].message }}
  • Profile picture of the author Shukri Sudin
    I'm having the same problem when fetching the keywords. I usually use MS to analyse the keywords.

    I am using keywordblaze for finding keywords. It's a free software..just google it, you'll find the download page.

    It'll sort your keywords into different categories ie winners, longtail, shopping keywords. Each keyword will be colour coded indicating the difficulty level to rank in google. Give it a try, it's pretty cool tool
    {{ DiscussionBoard.errors[5703568].message }}
  • Profile picture of the author outwest
    There is no way, that even when the MS kw tool is working properly , that it is better than Google adwords kw tool

    plus the adwords tool is 100 x faster
    so why use the MS tool>? for that function
    Signature
    Tech article writing .Native English Speaker(with Proof)
    specializing in SmartPhones , Internet security, high tech gadgets, search engines, tech shows, digital cameras.

    {{ DiscussionBoard.errors[5705328].message }}
  • Profile picture of the author deckman
    I got to chime in here as I am having the same problem. Running way too slow. I am about ready to use wordtracker even if it is a subscription based software.
    When I need these keywords I need them. I tried using the google synonym tool option as the video shows and when I go there to use it its not there and I cant find it.
    {{ DiscussionBoard.errors[5708928].message }}
  • Profile picture of the author leven
    thank you everyone for your thoughts.
    I have downloaded keyword blaze and am using it for now.
    I like MS - I hope they get the problem (whatever it is) fixed soon.
    {{ DiscussionBoard.errors[5710107].message }}
    • Profile picture of the author AprilCT
      Leven, can you tell us the differences between MS and K Blaze, please? I've also been considering getting MS, but haven't gotten it because I wanted to know what their monthly charge was going to be, or if they have decided yet.
      {{ DiscussionBoard.errors[5710429].message }}
  • Profile picture of the author leven
    UPDATE
    MS has an update (0.88.65) available now that will fix this problem
    {{ DiscussionBoard.errors[5710236].message }}

Trending Topics