WP issue with images.

7 replies
  • WEB DESIGN
  • |
Hi guys,

I have an issue that is starting to annoying me, well basically my website was created by a webdesigner and aobout that all was fine, the site has pictures and all is really fine.

The issue i have is the following:

When i upload to my media an image whatever is the extension (jpg, jpeg, bmp, etc it uploads real fast but i cannot see the thumbnail , its empty but i can edit the image and there i can see the image itself.

Then if i try to use this image in the blog i only see an empty square, so its not working either.

If i try to access to the image link i receive this message:

403 Forbidden

Access to this resource on the server is denied!


so how can i solve this issue?

I have already update to the last version of Wordpress but the problem continues, i also tried to look for the solution on the WP forums, but they were talking about checking the files permissions.... but how can i check them? should them were supposed to be read/write to the admin user right?

Thanks,
Morg
#images #issue
  • Profile picture of the author TDogger
    It looks like a possible permissions issue with the uploads directory. If you have an FTP utility, change the permissions for that directory to 777.

    You will find it at /wp-content/uploads/
    {{ DiscussionBoard.errors[6963259].message }}
    • Profile picture of the author morg2k2
      can i do it by the cpanel ftp tools?
      {{ DiscussionBoard.errors[6963266].message }}
  • Profile picture of the author TDogger
    You can set directory permissions using cPanel, as well. Use the File Manager.

    cPanel File Manager - File Permissions Tutorial
    {{ DiscussionBoard.errors[6963328].message }}
    • Profile picture of the author morg2k2
      ok thanks,
      i am going to check that out.

      regards,
      Morg
      {{ DiscussionBoard.errors[6963377].message }}
  • Profile picture of the author morg2k2
    thanks it worked.

    But i have just one doubt...

    i have this folder

    /wp-content/uploads/2012/

    then the following subfolders:
    01
    02
    03
    04
    05
    06
    07
    08
    09

    so if i had the permissions to the 2012 folder should it bypass the permissions to this sub-folders?

    because only the main folder received the 777 the subfolders did not received it, well i did it manually but it should be like in windows

    Thanks,
    Morg
    {{ DiscussionBoard.errors[6963478].message }}
  • Profile picture of the author TDogger
    When WordPress creates a new folder, it should inherit the permissions of the uploads folder.
    {{ DiscussionBoard.errors[6963601].message }}
    • Profile picture of the author morg2k2
      Ok.

      Thanks.
      Morg
      {{ DiscussionBoard.errors[6965619].message }}

Trending Topics