Google Analytics Content Experiments Causing 403 Forbidden Errors

6 replies
Hey Guys,

Just noticed something disturbing on one of my squeeze pages and one of my sales pages that I'm running split tests on in Google Analytics.

When I have an experiment running people will run into a "403 Forbidden" page when clicking on my link on SERPS, on my blog, on facebook, on an email, or an anchored link.

But if they enter my link directly into their browser, it comes up fine. Clicking on a Clickbank hoplink or PPC ad is also fine.

When I turn off the experiment all is well.

It's sad knowing that I've been working really hard driving traffic to a 403 page for this long. It's also sad that now I don't have a way to run split tests.

Any thoughts? Have any of you guys ever experience this? Is there a fix? Is there another free alternative that I can use?
#403 #analytics #causing #content #errors #experiments #forbidden #google
  • Profile picture of the author jjbalagosa
    No takers, eh? I usually don't get answers to my more technical posts.

    Well, for anyone that was lurking and curious of the outcome, I'm trying out a paid service now that doesn't seem to break the site. (As far as I can tell anyway.)

    It's a shame that I can't use the free tool that Google provides anymore, but you get what you pay for, I guess.
    {{ DiscussionBoard.errors[6635240].message }}
    • Profile picture of the author rshain

      I am experiencing the exact same problem. I created an a/b experiment using analytics for my homepage. If the user typed the URL directly no problem. Any organic links to my site, however, caused the 403 error. This was the case for my organic listings and my PPC links.

      If anyone has a clue how to fix this please share!
      {{ DiscussionBoard.errors[6691059].message }}
      • Profile picture of the author Mike Roncone
        I've never heard of that happening before, did either of you submit a help ticket to Google? I would be curious to know what they have to say about it. This isn't something that they would be too happy about I don't think.


        Founder & Web Strategist at Grae Web Strategies

        {{ DiscussionBoard.errors[6691128].message }}
  • Profile picture of the author jjbalagosa
    Originally Posted by BlueRiseMedia View Post

    Hey Jeff,

    Just wanted to let you know I got this resolved tonight. It ended up being a problem on our hosting side, HostGator. They told me there was an issue with a "plugin" and had to "whitelist" it... apparently it was giving some "Mod_security" error.

    I've asked for them to provide some more detail about the fix and haven't heard back yet. I said I was concerned, because I'm about to implement more instances of A / B testing on other domains and I wanted to know if there fix was GLOBAL or SPECIFIC to the one domain I've done this on so far... don't need to see this happen again after implementation number two :O)

    I've I get more info out of them, I'll pass it along. By the way, I also saw your note in a Google Forum and added to that as well. A Google Engineer contacted me tonight and I've been working with them as well. Haven't heard back from them either, but I did let them know that whatever HostGator did, seemed to fix the issue.

    Hopefully this helps you solve your issue. Let us all know.
    Thanks for the update! I'm using Hostgator too. Maybe the issue is related.

    I've since totally abandoned Google Analytics split testing and am using Optimizely now. I don't want to take the chance of something breaking and again getting absolutely no support, like what happened here.

    I'm glad you actually got through to someone. I never thought of it being on the hosting end. That was good thinking on your part to check with Hostgator.
    {{ DiscussionBoard.errors[7193689].message }}
    • Profile picture of the author Snow_Predator
      Did anyone sort this problem out? I'm experiencing the same thing. I've turned my experiment off for now, and am looking for a paid alternative to Google Analytics altogether.

      I've really had enough of Google. I gave up with SEO a good few months ago, and I no longer want them tracking my websites through their crappy analytics.
      {{ DiscussionBoard.errors[7526117].message }}
  • Profile picture of the author cre8iveq
    I know this is old, but when I was Googling the problem, this thread was high on the search results, so I thought I'd post the solution incase anyone else is searching for it.

    I had exactly the same thing. It worked fine when I went directly to the link, but if someone clicked on it from my Facebook ad, I got a 403 error.

    I rang my hosting provider (HostGator), and at first they tried to tell me it was Facebook that was breaking it. Always frustrating when you know more than the tech guy trying to fix your problem.

    After a long conversation, I convinced him to ask someone else, and when he did, he discovered that it was tripping some security thing they have on their side. They just whitelisted it, and it was good as gold.

    Long story short... call your hosting provider. If they say it's not their problem, they are wrong.
    {{ DiscussionBoard.errors[10400020].message }}

Trending Topics