Cannot insert hyperlinks or email links...

25 replies
  • WEB DESIGN
  • |
Hi there, this is a totally weird one. I have a html site that I took over completing but any hyperlink or email link i insert does not work. Here is the webpage:London Locksmith 24 Hr Burglary Repair

On the page I've got a supposedly hyperlink "Click here to download the brochure" yet it just does not work. Here is the html:

<p><a href="http://londonlocksmith.mobi/brochure.pdf">Click Here To Download Our Brochure</a></p>

I've tried in DW8 and CS and even smultron yet no links work on it. I am tearing my hair out what to do as my client wants his brochure to be downloadable from his site! Anybody got any idea?

Appreciate any help
#email #hyperlinks #insert #links
  • Profile picture of the author shmerns
    Hmm, sometimes you'll find these glitches. Let me ask you a question, are you trying to edit this in Internet Explorer?

    Switch over to Firefox and see if you have the same problem, sometimes the browser is the quick fix. Internet Explorer has lots of problems.

    Let me know if this works

    Lori P.
    Signature
    This May Just Be The Last Tool You EVER Use For Leads…
    www.LoriPetrosino.com
    {{ DiscussionBoard.errors[6069961].message }}
  • Profile picture of the author Sarah_Lyle
    Thanks for your fast reply Lori! Unfortunately it is still the same - I'm using a mac. Firefox and safari dont see it as a link - do you see it working as a link OK?
    {{ DiscussionBoard.errors[6070059].message }}
  • Profile picture of the author duluthminnesota
    Why do you have it broken down in to so many div tags? My Firebug doesn't even pick it up as text instead it appears as an image within 20 or so different div tags. What did you use to create this?
    {{ DiscussionBoard.errors[6070120].message }}
  • Profile picture of the author Istvan Horvath
    Signature

    {{ DiscussionBoard.errors[6070248].message }}
  • Profile picture of the author Sarah_Lyle
    Lol you are telling me it's a mess! Don't i know it! A well promoted designer warrior custom built this website for me - i was not happy, and i got banned from warrior forum for a few days because I complained all over his "for hire" thread! I am guessing its the awful coding that is buggering up any hyperlinks. I don't know what I am going to do because my client just wants a simple link here to his brochure and I cannot even do that. By the way anyone want the guy who designed this, so to know who to steer clear of pm me!
    {{ DiscussionBoard.errors[6070280].message }}
  • Profile picture of the author developdaly
    Wow, talk about DIV bloat. There's about 100 unnecessary nested DIVs. It's too hard to debug with all that, but I assume that something is being positioned over top of the links in such a way that its making links unclickable. The HTML for the links is correct though.
    {{ DiscussionBoard.errors[6070402].message }}
  • Profile picture of the author Sarah_Lyle
    Thank you developdaly, I don't suppose there is anything I can do then if the site is too messed up to debug ;(
    {{ DiscussionBoard.errors[6070449].message }}
  • Profile picture of the author developdaly
    If you aren't comfortable stripping out the unnecessary HTML or can't afford to pay anyone else to do it -- not really.
    {{ DiscussionBoard.errors[6070460].message }}
  • Profile picture of the author Istvan Horvath
    This forum is not for negotiating job offers... do it in private, if you need to.
    Signature

    {{ DiscussionBoard.errors[6071358].message }}
  • Profile picture of the author Sarah_Lyle
    Blimey, don't get your knickers in a twist, I wasn't offering any work. Just wondered how much it would cost.
    {{ DiscussionBoard.errors[6071841].message }}
    • Profile picture of the author Istvan Horvath
      Originally Posted by Sarah_Lyle View Post

      Blimey, don't get your knickers in a twist, I wasn't offering any work. Just wondered how much it would cost.
      The problem is: whenever you ask a question like that - there will be five eager candidates to give you their own price as a "quote" for that job.
      (Exactly what happened in this thread)

      And they all end up deleted... and if it continues, then the whole thread might get nuked.
      Signature

      {{ DiscussionBoard.errors[6072097].message }}
      • Profile picture of the author developdaly
        Originally Posted by Istvan Horvath View Post

        five eager candidates to give you their own price as a "quote" for that job.
        Which is somehow how not an accurate answer to her question?
        {{ DiscussionBoard.errors[6072254].message }}
  • Profile picture of the author Sarah_Lyle
    Well, Pixelgraffiti's useless coding strikes again. I found a nice chappie on fiverr to take a look at my hyperlink problem and he has discovered that its actually a style.css sheet problem. here's the culprit section:
    #content {
    background: url("images/content-wrapper-bg.png") repeat-x scroll 0 0 transparent;
    clear: both;
    min-height: 700px;
    margin: 0 auto;
    position: relative;
    width: 830px;
    z-index:-1;

    the z index:-1 has made the content page go underneath in the pecking order or somethin'. However, if I remove the z index altogether or change the minus to a plus - then hoorah the hyperlinks work! But get this, the hyperlinks work but I lose one of my top header images the body-bg.png - which is found in the style sheet here:

    #container {
    width: 1200px;
    margin: 0 auto;
    position: relative;
    background: url(images/body-bg.png) no-repeat;
    width: 1200px;

    I've tried adding a z-index of its own with a plus number but the image body-bg.png still does not show up if I remove the z index from the container section or make that a plus figure in order to get the hyperlinks to function.

    Does any stylesheet genius know why my body-bg.png disappears everytime I alter the container z-index? And does anyone have a solution?

    Grateful for any comments.

    Love
    Sarah xx
    {{ DiscussionBoard.errors[6098484].message }}
  • Profile picture of the author iuditg
    After opening 40 Div tags or so I decided to give up opening more div tags. This site is a real mess in terms of coding and performance. It's very very poorly coded.

    I did some performance testing on your and this is what I found :

    Total HTTP request sent : 43 requests
    Total Home Page size: 1.8 MB

    According to stats your site is a bad state.

    Z-Index Is normally used to overlap.

    In your situation the guy have used images extensively. Jezzzz the site is a mess.

    This is what I would suggest, get a new theme from themeforest for $8-10 (plain HTML/CSS) and then just edit the contents as per your need. Trust me you will save a lot of time and money.

    Or if you need something from custom scratch then hit me up a PM. I can make you a cool and sexy looking design template in 2-3 hours.
    {{ DiscussionBoard.errors[6098666].message }}
  • Profile picture of the author Sarah_Lyle
    Thanks uditg, I know the coding is terrible. I tried to get my money back from the original designer but got no-where. Even paypal would not refund. The thing is though I've already spent $360 for this mess and 3 weeks of content editing to get it looking half decent, compared to its dire original state. I cannot afford to spend anymore time and money on it.

    I just need an answer to this hyperlink fiasco and I can then hopefully put it to bed.
    {{ DiscussionBoard.errors[6099197].message }}
    • Profile picture of the author iuditg
      Originally Posted by Sarah_Lyle View Post

      Thanks uditg, I know the coding is terrible. I tried to get my money back from the original designer but got no-where. Even paypal would not refund. The thing is though I've already spent $360 for this mess and 3 weeks of content editing to get it looking half decent, compared to its dire original state. I cannot afford to spend anymore time and money on it.

      I just need an answer to this hyperlink fiasco and I can then hopefully put it to bed.
      Send me the source files and maybe I can help you out.
      {{ DiscussionBoard.errors[6102071].message }}
  • Profile picture of the author Sarah_Lyle
    Thanks Iuditg, have sent you a pm
    {{ DiscussionBoard.errors[6103706].message }}
  • Profile picture of the author Sarah_Lyle
    Still not got this resolved ;( BTW pixelgraffiti is going by the name of pixelx now. Buyer beware!
    {{ DiscussionBoard.errors[6125369].message }}
  • Profile picture of the author AdamWentworth
    You need to get in there, identify which <div> tags are completely useless, and rip them out. If the site was in a manageable state, we could try to help you debug with Firebug or a similar tool. However, in it's current state, it is just too messy to try to deal with. :\
    {{ DiscussionBoard.errors[6125627].message }}
  • Profile picture of the author Brad Hodge
    I think your problem was solved. The z-index value made the link useless. You simply couldnt reach it! So why not just change it!
    {{ DiscussionBoard.errors[6140960].message }}
  • Profile picture of the author Sarah_Lyle
    Brad dude, i could do that, and I did - only trouble is, one of my header images would disappear!!! It's so bizarre, I can either have hyperlinks and a big chunk of the website header background would go missing, or have a website that looks normal but no hyperlinks work in the content pages. It's hobson's choice. But thanks dude, I've got a tech guy warrior for hire going bald trying to figure it out
    {{ DiscussionBoard.errors[6141118].message }}
  • Profile picture of the author pinterest01
    i'll glad to help u, send the file to my email, i'll have a look on it
    Signature
    Visit My Portfolio | Hire me $10/Day | I'l setup your website, blog, ecommerce site, web 2.0 for FREE!* (PM for Details)
    {{ DiscussionBoard.errors[6143169].message }}
  • Profile picture of the author Sarah_Lyle
    Pinterest girlie, that is most kind of you. I have a tech guy looking at it now. If he cannot fix it I'll give you a shout. I'll pm you. Many thanks! Sarah
    {{ DiscussionBoard.errors[6146879].message }}
  • Profile picture of the author Alice R
    Don't worry about Istvan Sarah. He seems to go around on other peoples posts and correct things that didn't need correcting in the first place to run up a post count. Anyway, if you ned additional help, let me know. Coding is also going to be hard to get help with here anyway. Codingforums is a lot more helpful when it comes to problems like yours.
    {{ DiscussionBoard.errors[6154500].message }}
    • Profile picture of the author Istvan Horvath
      Originally Posted by Alice R View Post

      Don't worry about Istvan
      I would if I were you... especially when digging up a lot of old threads to add nothing to them!
      Signature

      {{ DiscussionBoard.errors[6154810].message }}

Trending Topics